CVE-2023-43615
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
CVE-2023-43615- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
CVE-2023-43615- Updated
- 2026-11-02
EUVDEUVD-2023-48021 No score
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
EUVD-2023-48021- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-656f-g689-89jh
7.5
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
GHSA-656f-g689-89jh- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVALPINE-CVE-2023-43615
7.5
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
ALPINE-CVE-2023-43615- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
OSVDEBIAN-CVE-2023-43615
7.5
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
DEBIAN-CVE-2023-43615- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVJLSEC-2025-222
7.5
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
JLSEC-2025-222- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-43615
7.5
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
UBUNTU-CVE-2023-43615- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSV No score
Mbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
- Record
CVE-2023-43615- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mbedtlsAlpine:v3.16 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.17 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.18 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.19 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.20 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.21 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.22 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.23 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsAlpine:v3.24 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtls2Alpine:v3.20 |
before 2.28.5-r0 | 2.28.5-r0 |
Show 13 moreShow less
| Package | Affected | Fixed |
|---|---|---|
mbedtls2Alpine:v3.21 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtls2Alpine:v3.22 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtls2Alpine:v3.23 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtls2Alpine:v3.24 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtls3Alpine:v3.24 |
before 2.28.5-r0 | 2.28.5-r0 |
mbedtlsDebian:12 |
All versions, plus listed versions 2.28.3-12.28.4-12.28.5-12.28.6-12.28.7-1 Show 18 moreShow less2.28.7-1.12.28.7-1.1~exp12.28.8-13.6.0-13.6.0-23.6.0-33.6.2-13.6.2-23.6.2-33.6.3-13.6.4-13.6.4-23.6.5-0.13.6.5-0.1~deb13u13.6.6-0.13.6.6-0.1~deb13u13.6.7-23.6.7-3 |
None known |
mbedtlsDebian:13 |
before 2.28.5-1 | 2.28.5-1 |
mbedtlsDebian:14 |
before 2.28.5-1 | 2.28.5-1 |
MbedTLS_jllJulia |
before 2.28.6+0 | 2.28.6+0 |
mbedtlsUbuntu:16.04:LTS |
All versions, plus listed versions 2.1.2-12.2.0-12.2.1-12.2.1-22.2.1-2ubuntu0.12.2.1-2ubuntu0.22.2.1-2ubuntu0.3 |
None known |
mbedtlsUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 2.5.1-1ubuntu12.6.0-12.7.0-22.8.0-12.8.0-1ubuntu0.1~esm1 |
None known |
mbedtlsUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 2.16.2-12.16.3-12.16.4-1ubuntu22.16.4-1ubuntu2+esm1 |
None known |
mbedtlsUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 2.16.9-0.1ubuntu12.16.11-0.1ubuntu12.16.11-0.32.28.0-12.28.0-1build12.28.0-1ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-43615 is a high vulnerability (CVSS 7.5) in Arm Mbed Tls, published October 7, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 61st percentile. Fixed in mbedtls 2.28.5-r0.
References
mbed-tls.readthedocs.io/en/latest/security-advisories/mbedtls-security-advisory-2023-10-1
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/O7SB7L6A56QZALDTOZ6O4X7PTC4I647R
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GGRB5MO2KUJKYPMGXMIZH2WRH6QR5UZS
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BDSHAANRULB57GVS5B3DZHXL5KCC7OWQ
nvd.nist.gov/vuln/detail/CVE-2023-43615
lists.fedoraproject.org/archives/list/[email protected]/message/BDSHAANRULB57GVS5B3DZHXL5KCC7OWQ
Show 8 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/GGRB5MO2KUJKYPMGXMIZH2WRH6QR5UZS
lists.fedoraproject.org/archives/list/[email protected]/message/O7SB7L6A56QZALDTOZ6O4X7PTC4I647R
github.com/advisories/GHSA-656f-g689-89jh
security.alpinelinux.org/vuln/CVE-2023-43615
github.com/CVEProject/cvelistV5/tree/main/cves/2023/43xxx/CVE-2023-43615.json
security-tracker.debian.org/tracker/CVE-2023-43615
ubuntu.com/security/CVE-2023-43615
cve.org/CVERecord?id=CVE-2023-43615