Every CVE Search/ Get API key

CVE-2024-34244

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue...

7.5 HighFix available

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.52%Up 0.5 points since May 9, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
CVE-2024-34244
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120, CWE-125
Updated
2026-11-02
EUVDEUVD-2024-34708 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
EUVD-2024-34708
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-crpf-8hgm-99cp 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue...

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
GHSA-crpf-8hgm-99cp
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
NVD 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
CVE-2024-34244
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120, CWE-125
Updated
2026-11-02
OSV 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
CVE-2024-34244
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVJLSEC-2026-1253 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
JLSEC-2026-1253
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-34244 7.5

libmodbus v3.1.10 is vulnerable to Buffer Overflow via the modbus_write_bits function. This issue can be triggered when the function is fed with specially crafted input, which leads to out-of-bounds read and can potentially cause a crash or other unintended behaviors.

Record
UBUNTU-CVE-2024-34244
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
LibModbus_jll
Julia
3.1.10+0 up to 3.1.12+0
3.1.12+0
libmodbus
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
3.0.4-13.0.5-13.0.5-1ubuntu0.1~esm1
None known
libmodbus
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.0.6-13.0.6-1ubuntu0.1~esm1
None known
libmodbus
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.6-23.0.6-2ubuntu0.1~esm13.0.6-2+deb9u1build0.18.04.1
None known
libmodbus
Ubuntu:20.04:LTS
All versions, plus listed versions
3.1.6-13.1.6-2
None known
libmodbus
Ubuntu:22.04:LTS
All versions, plus listed versions
3.1.6-2
None known
libmodbus
Ubuntu:24.04:LTS
All versions, plus listed versions
3.1.6-2.13.1.10-1ubuntu1
None known
libmodbus
Ubuntu:25.10
All versions, plus listed versions
3.1.11-2
None known
libmodbus
Ubuntu:26.10
All versions, plus listed versions
3.1.11-2build13.2.0-1
None known
libmodbus
Ubuntu:26.04:LTS
All versions, plus listed versions
3.1.11-23.1.11-2build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-34244 is a high vulnerability (CVSS 7.5) in Libmodbus, published May 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in LibModbus_jll 3.1.12+0.

References

MoveEnter Open