Every CVE Search/ Get API key

CVE-2013-2070

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when...

5.8 MediumFix available

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Exploit likelihood

11.9%Up 9.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Record
CVE-2013-2070
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Updated
2026-11-02
CVE List No score

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Record
CVE-2013-2070
Updated
2026-11-02
EUVDEUVD-2013-2050 No score

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Record
EUVD-2013-2050
Updated
2026-11-03
GitHub AdvisoriesGHSA-wwq6-8qmj-449j No score

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when...

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Record
GHSA-wwq6-8qmj-449j
Updated
2026-11-02
OSV No score

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Record
CVE-2013-2070
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2070 No score

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

Record
DEBIAN-CVE-2013-2070
Updated
2026-11-02
OSVMGASA-2013-0160 No score

Updated nginx package fixes security vulnerability

A security problem related to CVE-2013-2028 was identified, affecting some previous nginx versions if proxy_pass to untrusted upstream HTTP servers is used. The problem may lead to a denial of service or a disclosure of a worker process memory on a specially crafted response from an upstream proxied server (CVE-2013-2070).

Record
MGASA-2013-0160
Updated
2026-11-02
OSVopenSUSE-SU-2024:10044-1 No score

nginx-1.11.4-2.5 on GA media

These are all security issues fixed in the nginx-1.11.4-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10044-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nginx
Debian:12
before 1.4.1-1
1.4.1-1
nginx
Debian:13
before 1.4.1-1
1.4.1-1
nginx
Debian:14
before 1.4.1-1
1.4.1-1
nginx
Debian:7
before 1.2.1-2.2+wheezy1, plus listed versions
1.2.1-2.2
1.2.1-2.2+wheezy1
nginx
Mageia:3
before 1.2.9-1.1.mga3
1.2.9-1.1.mga3
nginx
openSUSE:Tumbleweed
From an advisory covering 11 CVEs
before 1.11.4-2.5
1.11.4-2.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2070 is a medium vulnerability (CVSS 5.8) in F5 Nginx, published June 6, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.9%, the 96th percentile. Fixed in nginx 1.4.1-1.

References

Show 21 moreShow less
MoveEnter Open