CVE-2013-2168
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4...
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
Exploit likelihood
What each source reports
NVD Score used
1.9
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
- Record
CVE-2013-2168- CVSS 2.0
- 1.9 Low
AV:L/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
- Record
CVE-2013-2168- Updated
- 2026-11-02
EUVDEUVD-2013-2128 No score
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
- Record
EUVD-2013-2128- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c26p-366m-4xv6 No score
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4...
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
- Record
GHSA-c26p-366m-4xv6- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV No score
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
- Record
CVE-2013-2168- Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-2168 No score
The _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
- Record
DEBIAN-CVE-2013-2168- Updated
- 2026-11-02
OSVMGASA-2013-0173 No score
Updated dbus packages fix security vulnerability
Alexandru Cornea discovered a vulnerability in libdbus caused by an implementation bug in _dbus_printf_string_upper_bound(). This vulnerability can be exploited by a local user to crash system services that use libdbus, causing denial of service. Depending on the dbus services running, it could lead to complete system crash (CVE-2013-2168).
This problem only currently appears to affect the x86_64 version of Mageia but we advise that all systems should be updated.
- Record
MGASA-2013-0173- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10517-1 No score
dbus-1-1.10.12-2.1 on GA media
These are all security issues fixed in the dbus-1-1.10.12-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10517-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dbusDebian:12 |
before 1.6.12-1 | 1.6.12-1 |
dbusDebian:13 |
before 1.6.12-1 | 1.6.12-1 |
dbusDebian:14 |
before 1.6.12-1 | 1.6.12-1 |
dbusDebian:7 |
before 1.6.8-1+deb7u1, plus listed versions 1.6.8-1 |
1.6.8-1+deb7u1 |
dbusMageia:2 |
before 1.4.16-5.2.mga2 | 1.4.16-5.2.mga2 |
dbusMageia:3 |
before 1.6.8-4.1.mga3 | 1.6.8-4.1.mga3 |
dbus-1openSUSE:Tumbleweed From an advisory covering 14 CVEs |
before 1.10.12-2.1 | 1.10.12-2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-2168 is a low vulnerability (CVSS 1.9) in Freedesktop Dbus, published June 13, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in dbus 1.6.12-1.
References
debian.org/security/2013/dsa-2707
lists.fedoraproject.org/pipermail/package-announce/2013-June/110114.html
lists.opensuse.org/opensuse-updates/2014-09/msg00049.html
mandriva.com/security/advisories?name=MDVSA-2013:177
lists.opensuse.org/opensuse-updates/2013-07/msg00003.html
secunia.com/advisories/53317
Show 29 moreShow less
lists.fedoraproject.org/pipermail/package-announce/2013-June/109896.html
bugzilla.redhat.com/show_bug.cgi?id=974109
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A16881
securitytracker.com/id/1028667
cgit.freedesktop.org/dbus/dbus/commit?id=954d75b2b64e4799f360d2a6bf9cff6d9fee37e7
ubuntu.com/usn/USN-1874-1
openwall.com/lists/oss-security/2013/06/13/2
secunia.com/advisories/53832
lists.freedesktop.org/archives/dbus/2013-June/015696.html
securityfocus.com/bid/60546
nvd.nist.gov/vuln/detail/CVE-2013-2168
github.com/advisories/GHSA-c26p-366m-4xv6
security-tracker.debian.org/tracker/CVE-2013-2168
advisories.mageia.org/MGASA-2013-0173.html
bugs.mageia.org/show_bug.cgi?id=10520
suse.com/security/cve/CVE-2010-4352
suse.com/security/cve/CVE-2012-3524
suse.com/security/cve/CVE-2013-2168
suse.com/security/cve/CVE-2014-3477
suse.com/security/cve/CVE-2014-3532
suse.com/security/cve/CVE-2014-3533
suse.com/security/cve/CVE-2014-3635
suse.com/security/cve/CVE-2014-3636
suse.com/security/cve/CVE-2014-3637
suse.com/security/cve/CVE-2014-3638
suse.com/security/cve/CVE-2014-3639
suse.com/security/cve/CVE-2014-7824
suse.com/security/cve/CVE-2014-8148
suse.com/security/cve/CVE-2015-0245