Every CVE Search/ Get API key

CVE-2013-2765

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a...

5.0 MediumPublic exploitFix available

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Exploit likelihood

13.7%Down 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
CVE-2013-2765
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
CVE-2013-2765
Updated
2026-11-02
EUVDEUVD-2013-2704 No score

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
EUVD-2013-2704
Updated
2026-11-03
GitHub AdvisoriesGHSA-x49q-wq3g-gh64 No score

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a...

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
GHSA-x49q-wq3g-gh64
Weakness
CWE-476
Updated
2026-11-02
OSV No score

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
CVE-2013-2765
Updated
2026-11-02
OSVDEBIAN-CVE-2013-2765 No score

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
DEBIAN-CVE-2013-2765
Updated
2026-11-02
OSVMGASA-2013-0179 No score

apache-mod_security new security issue CVE-2013-2765

Updated apache-mod_security packages fix security vulnerability:

When ModSecurity receives a request body with a size bigger than the value set by the "SecRequestBodyInMemoryLimit" and with a "Content-Type" that has no request body processor mapped to it, ModSecurity will systematically crash on every call to "forceRequestBodyVariable" (in phase 1) (CVE-2013-2765).

Record
MGASA-2013-0179
Updated
2026-11-02
OSVopenSUSE-SU-2024:10034-1 No score

apache2-mod_security2-2.9.0-5.6 on GA media

These are all security issues fixed in the apache2-mod_security2-2.9.0-5.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10034-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-2765 No score

The ModSecurity module before 2.7.4 for the Apache HTTP Server allows remote attackers to cause a denial of service (NULL pointer dereference, process crash, and disk consumption) via a POST request with a large body and a crafted Content-Type header.

Record
UBUNTU-CVE-2013-2765
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
modsecurity-apache
Debian:12
before 2.6.6-9
2.6.6-9
modsecurity-apache
Debian:13
before 2.6.6-9
2.6.6-9
modsecurity-apache
Debian:14
before 2.6.6-9
2.6.6-9
apache-mod_security
Mageia:2
before 2.6.3-3.5.mga2
2.6.3-3.5.mga2
apache-mod_security
Mageia:3
before 2.7.4-1.mga3
2.7.4-1.mga3
apache2-mod_security2
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 2.9.0-5.6
2.9.0-5.6

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBModSecurity - Remote Null Pointer Dereference2013-05-31

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2765 is a medium vulnerability (CVSS 5.0) in Trustwave Modsecurity, published June 26, 2013. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 13.7%, the 96th percentile. Fixed in modsecurity-apache 2.6.6-9.

References

Show 17 moreShow less
MoveEnter Open