Every CVE Search/ Get API key

CVE-2013-4277

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to...

3.3 LowFix available

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Exploit likelihood

0.69%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.3

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
CVE-2013-4277
CVSS 2.0
3.3 LowAV:L/AC:M/Au:N/C:N/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
CVE-2013-4277
Updated
2026-11-02
EUVDEUVD-2013-4176 No score

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
EUVD-2013-4176
Updated
2026-11-03
GitHub AdvisoriesGHSA-7hmj-c92j-fg6p No score

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to...

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
GHSA-7hmj-c92j-fg6p
Updated
2026-11-02
OSV No score

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
CVE-2013-4277
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4277 No score

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
DEBIAN-CVE-2013-4277
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2013-0275 No score

Updated subversion package fixes security vulnerability.

svnserve takes a --pid-file option which creates a file containing the process id it is running as. It does not take steps to ensure that the file it has been directed at is not a symlink. If the pid file is in a directory writeable by unprivileged users, the destination could be replaced by a symlink allowing for privilege escalation. svnserve does not create a pid file by default (CVE-2013-4277).

Record
MGASA-2013-0275
Updated
2026-11-02
OSVopenSUSE-SU-2024:10538-1 No score

libsvn_auth_gnome_keyring-1-0-1.9.5-1.1 on GA media

These are all security issues fixed in the libsvn_auth_gnome_keyring-1-0-1.9.5-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10538-1
Updated
2026-11-02
OSVSUSE-SU-2015:0709-1 No score

Security update for subversion

Subversion has been updated to fix a security problem:

* bnc#889849: Reveal authentication information through an md5
  collision attack on authentication realm (CVE-2014-3528)

Security Issues:

* CVE-2014-3528
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3528>
Record
SUSE-SU-2015:0709-1
Updated
2026-11-02
OSVUBUNTU-CVE-2013-4277 No score

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Record
UBUNTU-CVE-2013-4277
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
subversion
Debian:12
before 1.7.13-1
1.7.13-1
subversion
Debian:13
before 1.7.13-1
1.7.13-1
subversion
Debian:14
before 1.7.13-1
1.7.13-1
subversion
Mageia:2
before 1.7.13-1.mga2
1.7.13-1.mga2
subversion
Mageia:3
before 1.7.13-1.mga3
1.7.13-1.mga3
subversion
openSUSE:Tumbleweed
From an advisory covering 37 CVEs
before 1.9.5-1.1
1.9.5-1.1

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4277 is a low vulnerability (CVSS 3.3) in Apache Subversion, published September 13, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in subversion 1.7.13-1.

References

Show 59 moreShow less
MoveEnter Open