CVE-2013-4473
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler...
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
Exploit likelihood
What each source reports
NVD Score used
7.5
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
CVE-2013-4473- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
CVE-2013-4473- Updated
- 2026-11-02
EUVDEUVD-2013-4341 No score
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
EUVD-2013-4341- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gvvw-6cpg-ppq6 No score
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler...
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
GHSA-gvvw-6cpg-ppq6- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
CVE-2013-4473- Updated
- 2026-11-02
OSVDEBIAN-CVE-2013-4473 No score
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
DEBIAN-CVE-2013-4473- Updated
- 2026-11-02
Show 4 moreShow less
OSVMGASA-2013-0332 No score
Updated poppler packages fix multiple vulnerabilities
Updated poppler packages fix security vulnerabilities:
Poppler is found to be affected by a stack based buffer overflow vulnerability in the pdfseparate utility. Successfully exploiting this issue could allow remote attackers to execute arbitrary code in the context of the affected application. Failed exploits may result in denial-of-service conditions (CVE-2013-4473).
Poppler was found to have a user controlled format string vulnerability because it fails to sanitize user-supplied input. An attacker may exploit this issue to execute arbitrary code in the context of the vulnerable application. Failed exploit attempts will likely result in a denial-of-service condition (CVE-2013-4474).
- Record
MGASA-2013-0332- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10360-1 No score
libpoppler-cpp0-0.49.0-1.1 on GA media
These are all security issues fixed in the libpoppler-cpp0-0.49.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10360-1- Updated
- 2026-11-02
OSVUBUNTU-CVE-2013-4473 No score
Stack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
- Record
UBUNTU-CVE-2013-4473- Updated
- 2026-11-02
OSVUSN-2958-1 No score
poppler vulnerabilities
It was discovered that the poppler pdfseparate tool incorrectly handled certain filenames. A local attacker could use this issue to cause the tool to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only applied to Ubuntu 12.04 LTS. (CVE-2013-4473, CVE-2013-4474)
It was discovered that poppler incorrectly parsed certain malformed PDF documents. If a user or automated system were tricked into opening a crafted PDF file, an attacker could cause a denial of service or possibly execute arbitrary code with privileges of the user invoking the program. (CVE-2015-8868)
- Record
USN-2958-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
popplerDebian:12 |
before 0.18.4-9 | 0.18.4-9 |
popplerDebian:13 |
before 0.18.4-9 | 0.18.4-9 |
popplerDebian:14 |
before 0.18.4-9 | 0.18.4-9 |
popplerDebian:7 |
before 0.18.4-6+deb7u2, plus listed versions 0.18.4-60.18.4-6+deb7u1 |
0.18.4-6+deb7u2 |
popplerMageia:2 |
before 0.18.4-2.3.mga2 | 0.18.4-2.3.mga2 |
popplerMageia:3 |
before 0.22.1-1.1.mga3 | 0.22.1-1.1.mga3 |
popplerUbuntu:14.04:LTS |
before 0.24.5-2ubuntu4.4, plus listed versions 0.24.1-0ubuntu10.24.3-0ubuntu10.24.3-0ubuntu20.24.3-0ubuntu30.24.3-0ubuntu4 Show 13 moreShow less0.24.3-0ubuntu50.24.3-0ubuntu60.24.3-0ubuntu70.24.3-0ubuntu80.24.3-0ubuntu100.24.3-0ubuntu120.24.5-0ubuntu30.24.5-2ubuntu10.24.5-2ubuntu20.24.5-2ubuntu40.24.5-2ubuntu4.10.24.5-2ubuntu4.20.24.5-2ubuntu4.3 |
0.24.5-2ubuntu4.4 |
poppleropenSUSE:Tumbleweed |
before 0.49.0-1.1 | 0.49.0-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2013-4473 is a high vulnerability (CVSS 7.5) in Freedesktop Poppler, published November 20, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.13%, the 94th percentile. Fixed in poppler 0.18.4-9.
References
bugs.debian.org/723124
secunia.com/advisories/56567
security.gentoo.org/glsa/glsa-201401-21.xml
bugs.freedesktop.org/show_bug.cgi?id=69434
ubuntu.com/usn/USN-2958-1
cgit.freedesktop.org/poppler/poppler/commit/utils/pdfseparate.cc?id=b8682d868ddf7f741e93b
Show 30 moreShow less
cgit.freedesktop.org/poppler/poppler/tree/NEWS
securityfocus.com/bid/63368
openwall.com/lists/oss-security/2013/10/29/1
nvd.nist.gov/vuln/detail/CVE-2013-4473
github.com/advisories/GHSA-gvvw-6cpg-ppq6
security-tracker.debian.org/tracker/CVE-2013-4473
advisories.mageia.org/MGASA-2013-0332.html
lists.fedoraproject.org/pipermail/package-announce/2013-November/121297.html
bugs.mageia.org/show_bug.cgi?id=11560
ubuntu.com/security/CVE-2013-4473
ubuntu.com/security/notices/USN-2958-1
cve.org/CVERecord?id=CVE-2013-4473
ubuntu.com/security/CVE-2013-4474
ubuntu.com/security/CVE-2015-8868
suse.com/security/cve/CVE-2009-0799
suse.com/security/cve/CVE-2009-0800
suse.com/security/cve/CVE-2009-1179
suse.com/security/cve/CVE-2009-1180
suse.com/security/cve/CVE-2009-1181
suse.com/security/cve/CVE-2009-1182
suse.com/security/cve/CVE-2009-1183
suse.com/security/cve/CVE-2009-1187
suse.com/security/cve/CVE-2009-1188
suse.com/security/cve/CVE-2009-3607
suse.com/security/cve/CVE-2009-3608
suse.com/security/cve/CVE-2013-1788
suse.com/security/cve/CVE-2013-1789
suse.com/security/cve/CVE-2013-1790
suse.com/security/cve/CVE-2013-4473
suse.com/security/cve/CVE-2013-4474