Every CVE Search/ Get API key

CVE-2014-4911

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3...

5.0 MediumFix available

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.

Exploit likelihood

2.43%Up 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.

Record
CVE-2014-4911
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-310
Updated
2026-11-02
CVE List No score

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.

Record
CVE-2014-4911
Updated
2026-11-02
EUVDEUVD-2014-4830 No score

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.

Record
EUVD-2014-4830
Updated
2026-11-03
GitHub AdvisoriesGHSA-5w2p-5ww5-p9p9 No score

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3...

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.

Record
GHSA-5w2p-5ww5-p9p9
Updated
2026-11-02
OSVMGASA-2014-0315 No score

Updated polarssl packages fix security vulnerability

A flaw was discovered in PolarSSL, a lightweight crypto and SSL/TLS library, which can be exploited by a remote unauthenticated attacker to mount a denial of service against PolarSSL servers that offer GCM ciphersuites. Potentially clients are affected too if a malicious server decides to execute the denial of service attack against its clients (CVE-2014-4911).

The pdns package has been rebuilt against the updated polarssl library.

Record
MGASA-2014-0315
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
polarssl
Debian:6.0
before 1.2.9-1~deb6u2, plus listed versions
0.12.1-10.12.1-1squeeze10.14.3-11.0.0-11.0.0-2
Show 18 moreShow less
1.0.0-2+s390x1.0.0-31.1.0-11.1.1-11.1.2-11.1.3-11.1.4-11.1.4-21.2.0-11.2.2-11.2.3-11.2.4-11.2.5-11.2.6-11.2.7-11.2.8-11.2.8-21.2.9-1~deb6u1
1.2.9-1~deb6u2
polarssl
Debian:7
before 1.2.9-1~deb7u3, plus listed versions
1.1.4-21.2.0-11.2.2-11.2.3-11.2.4-1
Show 12 moreShow less
1.2.5-11.2.6-11.2.7-11.2.8-11.2.8-21.2.9-1~deb6u11.2.9-1~deb6u21.2.9-1~deb6u31.2.9-1~deb6u41.2.9-1~deb6u51.2.9-1~deb7u11.2.9-1~deb7u2
1.2.9-1~deb7u3
polarssl
Mageia:3
before 1.3.8-1.mga3
1.3.8-1.mga3
pdns
Mageia:3
before 3.3.1-1.3.mga3
3.3.1-1.3.mga3
polarssl
Mageia:4
before 1.3.8-1.mga4
1.3.8-1.mga4
pdns
Mageia:4
before 3.3.1-2.2.mga4
3.3.1-2.2.mga4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-4911 is a medium vulnerability (CVSS 5.0) in Polarssl, published July 18, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.43%, the 84th percentile. Fixed in polarssl 1.2.9-1~deb6u2.

References

MoveEnter Open