Every CVE Search/ Get API key

CVE-2014-8483

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to...

5.0 MediumFix available

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Exploit likelihood

3.55%Up 1.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
CVE-2014-8483
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
CVE-2014-8483
Updated
2026-11-02
EUVDEUVD-2014-8320 No score

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
EUVD-2014-8320
Updated
2026-11-03
GitHub AdvisoriesGHSA-vgxr-2jwm-83q2 No score

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to...

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
GHSA-vgxr-2jwm-83q2
Weakness
CWE-125
Updated
2026-11-02
OSV No score

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
CVE-2014-8483
Updated
2026-11-02
OSVDEBIAN-CVE-2014-8483 No score

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
DEBIAN-CVE-2014-8483
Updated
2026-11-02
Show 4 moreShow less
OSVMGASA-2014-0436 No score

Updated quassel packages fix security vulnerability

Due to and out-of-bounds read issue in Quassel core in The ECB Blowfish decryption function, a malicious client can cause either denial of service or disclosure of information from process memory by using an improperly formed message (CVE-2014-8483).

Record
MGASA-2014-0436
Updated
2026-11-02
OSVMGASA-2014-0437 No score

Updated konversation package fixes security vulnerability

Due to and out-of-bounds read issue in Konversation in The ECB Blowfish decryption function, a malicious client can cause either denial of service or disclosure of information from process memory by using an improperly formed message (CVE-2014-8483).

Record
MGASA-2014-0437
Updated
2026-11-02
OSVopenSUSE-SU-2024:10238-1 No score

konversation-1.6.2-1.3 on GA media

These are all security issues fixed in the konversation-1.6.2-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10238-1
Updated
2026-11-02
OSVUBUNTU-CVE-2014-8483 No score

The blowfishECB function in core/cipher.cpp in Quassel IRC 0.10.0 allows remote attackers to cause a denial of service (out-of-bounds read) via a malformed string.

Record
UBUNTU-CVE-2014-8483
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
konversation
Debian:12
before 1.5-2
1.5-2
konversation
Debian:13
before 1.5-2
1.5-2
konversation
Debian:14
before 1.5-2
1.5-2
quassel
Debian:12
before 0.10.0-2.1
0.10.0-2.1
quassel
Debian:13
before 0.10.0-2.1
0.10.0-2.1
quassel
Debian:14
before 0.10.0-2.1
0.10.0-2.1
konversation
Debian:6.0
before 1.3.1-2+deb6u1, plus listed versions
1.3.1-2
1.3.1-2+deb6u1
quassel
Debian:7
before 0.8.0-1+deb7u3, plus listed versions
0.8.0-10.8.0-1+deb7u10.8.0-1+deb7u2
0.8.0-1+deb7u3
konversation
Debian:7
before 1.4-1+deb7u1, plus listed versions
1.4-1
1.4-1+deb7u1
quassel
Mageia:3
before 0.9.2-1.1.mga3
0.9.2-1.1.mga3
Show 5 moreShow less
Affected packages
PackageAffectedFixed
quassel
Mageia:4
before 0.9.2-1.1.mga4
0.9.2-1.1.mga4
konversation
Mageia:3
before 1.5-0.rc1.2.mga3
1.5-0.rc1.2.mga3
konversation
Mageia:4
before 1.5-0.rc1.3.mga4
1.5-0.rc1.3.mga4
konversation
Ubuntu:14.04:LTS
before 1.5-1ubuntu1.14.04.1, plus listed versions
1.5~rc1+git20130415-0ubuntu11.5-0ubuntu11.5-1ubuntu1
1.5-1ubuntu1.14.04.1
quassel
Ubuntu:14.04:LTS
before 0.10.0-0ubuntu2.1, plus listed versions
0.9.1-0ubuntu10.9.2-0ubuntu10.9.2-0ubuntu20.9.2-0ubuntu30.9.2-0ubuntu4
Show 4 moreShow less
0.10~beta1-0ubuntu10.10~rc1-0ubuntu10.10.0-0ubuntu10.10.0-0ubuntu2
0.10.0-0ubuntu2.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8483 is a medium vulnerability (CVSS 5.0) in Quassel-irc Quassel Irc, published October 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.55%, the 89th percentile. Fixed in konversation 1.5-2.

References

Show 19 moreShow less
MoveEnter Open