Every CVE Search/ Get API key

CVE-2013-4440

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it...

5.0 MediumFix available

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Exploit likelihood

1.85%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Record
CVE-2013-4440
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-255
Updated
2026-11-02
CVE List No score

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Record
CVE-2013-4440
Updated
2026-11-02
EUVDEUVD-2013-4312 No score

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Record
EUVD-2013-4312
Updated
2026-11-03
GitHub AdvisoriesGHSA-62pg-hjc9-8wrw No score

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it...

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Record
GHSA-62pg-hjc9-8wrw
Updated
2026-11-02
OSV No score

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Record
CVE-2013-4440
Updated
2026-11-02
OSVDEBIAN-CVE-2013-4440 No score

Password Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.

Record
DEBIAN-CVE-2013-4440
Updated
2026-11-02
OSVMGASA-2014-0535 No score

Updated pwgen package fixes security vulnerabilities

Updated pwgen package fixes security vulnerabilities:

Pwgen was found to generate weak non-tty passwords by default, which could be brute-forced with a commendable success rate, which could raise security concerns (CVE-2013-4440).

Pwgen was found to silently falling back to use standard pseudo generated numbers on the systems that heavily use entropy. Systems, such as those with a lot of daemons providing encryption services, the entropy was found to be exhausted, which forces pwgen to fall back to use standard pseudo generated numbers (CVE-2013-4442).

Record
MGASA-2014-0535
Updated
2026-11-02
OSVopenSUSE-SU-2024:10333-1 No score

pwgen-2.07-2.7 on GA media

These are all security issues fixed in the pwgen-2.07-2.7 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10333-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pwgen
Debian:12
before 2.07-1
2.07-1
pwgen
Debian:13
before 2.07-1
2.07-1
pwgen
Debian:14
before 2.07-1
2.07-1
pwgen
Mageia:4
From an advisory covering 2 CVEs
before 2.07-1.mga4
2.07-1.mga4
pwgen
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 2.07-2.7
2.07-2.7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4440 is a medium vulnerability (CVSS 5.0) in Pwgen Project Pwgen, published December 19, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.85%, the 79th percentile. Fixed in pwgen 2.07-1.

References

Show 8 moreShow less
MoveEnter Open