Every CVE Search/ Get API key

CVE-2014-4165

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web...

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web script or HTML via the title parameter in a list action to plugins/rrdPlugin.

Exploit likelihood

2.09%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web script or HTML via the title parameter in a list action to plugins/rrdPlugin.

Record
CVE-2014-4165
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web script or HTML via the title parameter in a list action to plugins/rrdPlugin.

Record
CVE-2014-4165
Updated
2026-11-02
EUVDEUVD-2014-4096 No score

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web script or HTML via the title parameter in a list action to plugins/rrdPlugin.

Record
EUVD-2014-4096
Updated
2026-11-03
GitHub AdvisoriesGHSA-hpqj-mcx7-qqxg No score

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web...

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web script or HTML via the title parameter in a list action to plugins/rrdPlugin.

Record
GHSA-hpqj-mcx7-qqxg
Weakness
CWE-79
Updated
2026-11-02
OSVMGASA-2015-0168 No score

Updated ntop packages fix CVE-2014-4165

Updated ntop package fixes security vulnerability:

Lack of filtering in the title parameter of links to rrdPlugin allowed cross-site-scripting (XSS) attacks against users of the web interface (CVE-2014-4165).

Record
MGASA-2015-0168
Updated
2026-11-02
OSVUBUNTU-CVE-2014-4165 No score

Cross-site scripting (XSS) vulnerability in ntop allows remote attackers to inject arbitrary web script or HTML via the title parameter in a list action to plugins/rrdPlugin.

Record
UBUNTU-CVE-2014-4165
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ntop
Mageia:4
before 5.0.1-4.1.mga4
5.0.1-4.1.mga4
ntop
Ubuntu:16.04:LTS
All versions, plus listed versions
3:5.0.1+dfsg1-2.1ubuntu23:5.0.1+dfsg1-2.2ubuntu1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-4165 is a medium vulnerability (CVSS 4.3) in Ntop, published June 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.09%, the 81st percentile. Fixed in ntop 5.0.1-4.1.mga4.

References

Show 5 moreShow less
MoveEnter Open