Every CVE Search/ Get API key

CVE-2016-5017

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when...

8.1 HighFix available

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

6.79%Up 3.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.1

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
CVE-2016-5017
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
CVE-2016-5017
Updated
2026-11-02
EUVDEUVD-2016-5972 No score

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
EUVD-2016-5972
Updated
2026-11-03
GitHub AdvisoriesGHSA-85r2-fvq8-6xw9 8.1

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when...

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
GHSA-85r2-fvq8-6xw9
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 8.1

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
CVE-2016-5017
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-5017 8.1

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
DEBIAN-CVE-2016-5017
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-5017 8.1

Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and 3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows attackers to have unspecified impact via a long command string.

Record
UBUNTU-CVE-2016-5017
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2016-0328 No score

Updated zookeeper packages fix security vulnerability

Lyon Yang discovered that the C client shells cli_st and cli_mt of Apache Zookeeper were affected by a buffer overflow vulnerability associated with parsing of the input command when using the "cmd:" batch mode syntax. If the command string exceeds 1024 characters a buffer overflow will occur (CVE-2016-5017).

Record
MGASA-2016-0328
Updated
2026-11-02
OSVUSN-4789-1 No score

zookeeper vulnerabilities

It was discovered that Apache ZooKeeper incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service or other unspecified impact. (CVE-2016-5017)

It was discovered that Apache ZooKeeper incorrectly implemented "wchp/wchc" commands. An attacker could possibly use this issue to cause a denial of service. (CVE-2017-5637)

It was discovered that Apache Zookeeper incorrectly handled clusters. An attacker could possibly use this issue to obtain sensitive information. This issue only affected Ubuntu 16.04 ESM. (CVE-2018-8012)

Record
USN-4789-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zookeeper
Debian:12
before 3.4.9-1
3.4.9-1
zookeeper
Debian:13
before 3.4.9-1
3.4.9-1
zookeeper
Debian:14
before 3.4.9-1
3.4.9-1
zookeeper
Debian:7
before 3.3.5+dfsg1-2+deb7u1, plus listed versions
3.3.5+dfsg1-2
3.3.5+dfsg1-2+deb7u1
zookeeper
Mageia:5
before 3.4.5-25.1.mga5
3.4.5-25.1.mga5
zookeeper
Ubuntu:Pro:14.04:LTS
before 3.4.5+dfsg-1ubuntu0.1~esm1, plus listed versions
3.4.5+dfsg-1
3.4.5+dfsg-1ubuntu0.1~esm1
zookeeper
Ubuntu:Pro:16.04:LTS
before 3.4.8-1ubuntu0.1~esm1, plus listed versions
3.4.6-83.4.7-13.4.8-1
3.4.8-1ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-5017 is a high vulnerability (CVSS 8.1) in Apache Zookeeper, published September 18, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.79%, the 94th percentile. Fixed in zookeeper 3.4.9-1.

References

Show 23 moreShow less
MoveEnter Open