Every CVE Search/ Get API key

CVE-2016-7867

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable...

8.8 High

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable buffer overflow / underflow vulnerability in the RegExp class related to bookmarking in searches. Successful exploitation could lead to arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

11.0%Up 6.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable buffer overflow / underflow vulnerability in the RegExp class related to bookmarking in searches. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2016-7867
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable buffer overflow / underflow vulnerability in the RegExp class related to bookmarking in searches. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2016-7867
Updated
2026-11-02
EUVDEUVD-2016-8716 No score

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable buffer overflow / underflow vulnerability in the RegExp class related to bookmarking in searches. Successful exploitation could lead to arbitrary code execution.

Record
EUVD-2016-8716
Updated
2026-11-03
GitHub AdvisoriesGHSA-gcxq-976r-wv2c 9.8

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable...

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable buffer overflow / underflow vulnerability in the RegExp class related to bookmarking in searches. Successful exploitation could lead to arbitrary code execution.

Record
GHSA-gcxq-976r-wv2c
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-787
Updated
2026-11-02
OSVRHSA-2016:2947 8.8

Red Hat Security Advisory: flash-plugin security update

Record
RHSA-2016:2947
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0014 No score

Updated flash-player-plugin packages fix security vulnerabilities

Adobe Flash Player 24.0.0.194 contains fixes to critical security vulnerabilities found in earlier versions that could potentially allow an attacker to take control of the affected system.

Adobe is aware of a report that an exploit for CVE-2016-7892 exists in the wild, and is being used in limited, targeted attacks against users running Internet Explorer (32-bit) on Windows.

This update resolves security bypass vulnerabilities (CVE-2016-7890, CVE-2017-2938).

This update resolves use-after-free vulnerabilities that could lead to code execution (CVE-2016-7872, CVE-2016-7877, CVE-2016-7878, CVE-2016-7879, CVE-2016-7880, CVE-2016-7881, CVE-2016-7892, CVE-2017-2932, CVE-2017-2936, CVE-2017-2937).

This update resolves buffer overflow vulnerabilities that could lead to code execution (CVE-2016-7867, CVE-2016-7868, CVE-2016-7869, CVE-2016-7870, CVE-2017-2927, CVE-2017-2933, CVE-2017-2934, CVE-2017-2935).

This update resolves memory corruption vulnerabilities that could lead to code execution (CVE-2016-7871, CVE-2016-7873, CVE-2016-7874, CVE-2016-7875, CVE-2016-7876, CVE-2017-2925, CVE-2017-2926, CVE-2017-2928, CVE-2017-2930, CVE-2017-2931).

Note that Adobe has dropped Adobe Access DRM support from all their Linux releases since their 11.2 release series (which no longer gets security updates), so any Flash content protected with Adobe Access will no longer work.

Record
MGASA-2017-0014
Updated
2026-11-02
OSVSUSE-SU-2016:3148-1 No score

Security update for flash-player

This update for flash-player fixes the following issues:

  • Security update to 24.0.0.186 (bsc#1015379) APSB16-39:
    • These updates resolve use-after-free vulnerabilities that could have lead to code execution (CVE-2016-7872, CVE-2016-7877, CVE-2016-7878, CVE-2016-7879, CVE-2016-7880, CVE-2016-7881, CVE-2016-7892).
    • These updates resolve buffer overflow vulnerabilities that could have lead to code execution (CVE-2016-7867, CVE-2016-7868, CVE-2016-7869, CVE-2016-7870).
    • These updates resolve memory corruption vulnerabilities that could have lead to code execution (CVE-2016-7871, CVE-2016-7873, CVE-2016-7874, CVE-2016-7875, CVE-2016-7876).
    • These updates resolve a security bypass vulnerability (CVE-2016-7890).
  • Keep standalone flashplayer at version 11, no newer version exists (INSECURE!).
  • Update EULA to version 24.0.
Record
SUSE-SU-2016:3148-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-player-plugin
Mageia:5
From an advisory covering 30 CVEs
before 24.0.0.194-1.mga5.nonfree
24.0.0.194-1.mga5.nonfree
flash-plugin
Red Hat:rhel_extras:6
From an advisory covering 17 CVEs
before 0:24.0.0.186-1.el6_8
0:24.0.0.186-1.el6_8
flash-player
SUSE:Linux Enterprise Desktop 12 SP1
From an advisory covering 17 CVEs
before 24.0.0.186-152.1
24.0.0.186-152.1
flash-player
SUSE:Linux Enterprise Workstation Extension 12 SP1
From an advisory covering 17 CVEs
before 24.0.0.186-152.1
24.0.0.186-152.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-7867 is a high vulnerability (CVSS 8.8) in Adobe Flash Player, published December 14, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 11.0%, the 95th percentile. No source names a fixed version.

References

Show 82 moreShow less
MoveEnter Open