Every CVE Search/ Get API key

CVE-2017-8342

Radicale is vulnerable to timing oracles and simple bruteforce attacks

8.1 HighFix available

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.03%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
CVE-2017-8342
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-362
Updated
2026-11-02
CVE List No score

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
CVE-2017-8342
Updated
2026-11-02
EUVDEUVD-2017-0110 No score

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
EUVD-2017-0110
Updated
2026-11-03
GitHub AdvisoriesGHSA-rpv4-63g3-9x23 8.1

Radicale is vulnerable to timing oracles and simple bruteforce attacks

Radicale before 1.1.2 and 2.0.0rc1 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
GHSA-rpv4-63g3-9x23
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
OSV 8.1

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
CVE-2017-8342
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-8342 8.1

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
DEBIAN-CVE-2017-8342
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-rpv4-63g3-9x23 8.1

Radicale is vulnerable to timing oracles and simple bruteforce attacks

Radicale before 1.1.2 and 2.0.0rc1 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
GHSA-rpv4-63g3-9x23
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-362
Updated
2026-11-02
OSVUBUNTU-CVE-2017-8342 8.1

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
UBUNTU-CVE-2017-8342
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0140 No score

Updated radicale package fixes security vulnerability

Radicale before 1.1.2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method (CVE-2017-8342).

Record
MGASA-2017-0140
Updated
2026-11-02
OSVPYSEC-2017-102 No score

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Record
PYSEC-2017-102
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
radicale
PyPI
before 1.1.2
1.1.2
radicale
PyPI
2.0.0rc1 to 2.0.0rc1
2.0.0rc2
radicale
Debian:12
before 1.1.1+20160115-4
1.1.1+20160115-4
radicale
Debian:13
before 1.1.1+20160115-4
1.1.1+20160115-4
radicale
Debian:14
before 1.1.1+20160115-4
1.1.1+20160115-4
radicale
Debian:8
before 0.9-1+deb8u2, plus listed versions
0.9-10.9-1+deb8u1
0.9-1+deb8u2
radicale
Debian:7
before 0.7-1.1+deb7u2, plus listed versions
0.7-1.10.7-1.1+deb7u1
0.7-1.1+deb7u2
radicale
PyPI
before 1.1.2, plus listed versions
0.100.20.30.40.5
Show 15 moreShow less
0.60.6.10.6.20.6.30.6.40.70.7.10.80.90.9b10.9b21.01.0.11.11.1.1
1.1.2
radicale
PyPI
2.0.0rc1 up to 2.0.0rc2
2.0.0rc2
radicale
Mageia:5
before 1.1.1-1.2.mga5
1.1.1-1.2.mga5
radicale
PyPI
before 1.1.2, plus listed versions
0.100.20.30.40.5
Show 18 moreShow less
0.60.6.10.6.20.6.30.6.40.70.7.10.80.90.9b10.9b21.01.0.11.11.1.12.0.0rc1archive/1.0.x0.1
1.1.2
radicale
Ubuntu:16.04:LTS
All versions, plus listed versions
0.10-21.0-11.0.1-11.0.1-21.1.1-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-8342 is a high vulnerability (CVSS 8.1) in Radicale, published April 30, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.03%, the 81st percentile. Fixed in radicale 1.1.2.

References

Show 10 moreShow less
MoveEnter Open