Every CVE Search/ Get API key

CVE-2017-9078

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution...

8.8 HighFix available

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.47%Up 3.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
CVE-2017-9078
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
8.5 HighAV:N/AC:M/Au:S/C:C/I:C/A:C
Weakness
CWE-415
Updated
2026-11-02
CVE List No score

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
CVE-2017-9078
Updated
2026-11-02
EUVDEUVD-2017-18017 No score

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
EUVD-2017-18017
Updated
2026-11-03
GitHub AdvisoriesGHSA-p8gj-w7rh-3g6f 8.1

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution...

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
GHSA-p8gj-w7rh-3g6f
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-415
Updated
2026-11-02
OSVALPINE-CVE-2017-9078 8.8

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
ALPINE-CVE-2017-9078
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 8.8

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
CVE-2017-9078
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-9078 8.8

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
DEBIAN-CVE-2017-9078
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-9078 8.8

The server in Dropbear before 2017.75 might allow post-authentication root remote code execution because of a double free in cleanup of TCP listeners when the -a option is enabled.

Record
UBUNTU-CVE-2017-9078
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2017-0165 No score

Updated dropbear packages fix security vulnerability

A double-free in the server could be triggered by an authenticated user if dropbear is running with -a (CVE-2017-9078). The default Mageia configuration does not set -a, so is not vulnerable

Dropbear parsed authorized_keys as root, even if it were a symlink. The fix is to switch to user permissions when opening authorized_keys (CVE-2017-9079)

Record
MGASA-2017-0165
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dropbear
Alpine:v3.4
before 2017.75-r0
2017.75-r0
dropbear
Alpine:v3.5
before 2017.75-r0
2017.75-r0
dropbear
Debian:12
before 2016.74-5
2016.74-5
dropbear
Debian:13
before 2016.74-5
2016.74-5
dropbear
Debian:14
before 2016.74-5
2016.74-5
dropbear
Debian:8
From an advisory covering 2 CVEs
before 2014.65-1+deb8u2, plus listed versions
2014.65-12014.65-1+deb8u1
2014.65-1+deb8u2
dropbear
Mageia:5
From an advisory covering 2 CVEs
before 2014.66-1.3.mga5
2014.66-1.3.mga5
dropbear
Ubuntu:16.04:LTS
All versions, plus listed versions
2014.65-1ubuntu22015.68-12015.70-12015.71-12016.72-1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9078 is a high vulnerability (CVSS 8.8) in Debian Linux, published May 19, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.47%, the 92nd percentile. Fixed in dropbear 2017.75-r0.

References

Show 6 moreShow less
MoveEnter Open