Every CVE Search/ Get API key

CVE-2016-9422

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag...

8.8 HighFix available

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.18%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
CVE-2016-9422
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
CVE-2016-9422
Updated
2026-11-02
EUVDEUVD-2016-10232 No score

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
EUVD-2016-10232
Updated
2026-11-03
GitHub AdvisoriesGHSA-q689-7jq5-856w 8.8

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag...

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
GHSA-q689-7jq5-856w
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 8.8

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
CVE-2016-9422
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9422 8.8

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
DEBIAN-CVE-2016-9422
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2016-9422 8.8

An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-31. The feed_table_tag function in w3m doesn't properly validate the value of table span, which allows remote attackers to cause a denial of service (stack and/or heap buffer overflow) and possibly execute arbitrary code via a crafted HTML page.

Record
UBUNTU-CVE-2016-9422
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0024 No score

Updated w3m packages fix security vulnerability

The w3m package has been updated to a newer git snapshot to fix several security issues.

Record
MGASA-2018-0024
Updated
2026-11-02
OSVSUSE-SU-2016:3046-1 No score

Security update for w3m

This update for w3m fixes the following issues:

  • update to debian git version (bsc#1011293) addressed security issues: CVE-2016-9621: w3m: global-buffer-overflow write (bsc#1012020) CVE-2016-9622: w3m: null deref (bsc#1012021) CVE-2016-9623: w3m: null deref (bsc#1012022) CVE-2016-9624: w3m: near-null deref (bsc#1012023) CVE-2016-9625: w3m: stack overflow (bsc#1012024) CVE-2016-9626: w3m: stack overflow (bsc#1012025) CVE-2016-9627: w3m: heap overflow read + deref (bsc#1012026) CVE-2016-9628: w3m: null deref (bsc#1012027) CVE-2016-9629: w3m: null deref (bsc#1012028) CVE-2016-9630: w3m: global-buffer-overflow read (bsc#1012029) CVE-2016-9631: w3m: null deref (bsc#1012030) CVE-2016-9632: w3m: global-buffer-overflow read (bsc#1012031) CVE-2016-9633: w3m: OOM (bsc#1012032) CVE-2016-9434: w3m: null deref (bsc#1011283) CVE-2016-9435: w3m: use uninit value (bsc#1011284) CVE-2016-9436: w3m: use uninit value (bsc#1011285) CVE-2016-9437: w3m: write to rodata (bsc#1011286) CVE-2016-9438: w3m: null deref (bsc#1011287) CVE-2016-9439: w3m: stack overflow (bsc#1011288) CVE-2016-9440: w3m: near-null deref (bsc#1011289) CVE-2016-9441: w3m: near-null deref (bsc#1011290) CVE-2016-9442: w3m: potential heap buffer corruption (bsc#1011291) CVE-2016-9443: w3m: null deref (bsc#1011292)
Record
SUSE-SU-2016:3046-1
Updated
2026-11-02
OSVUSN-3214-1 No score

w3m vulnerabilities

A large number of security issues were discovered in the w3m browser. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

Record
USN-3214-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
w3m
Debian:12
before 0.5.3-30
0.5.3-30
w3m
Debian:13
before 0.5.3-30
0.5.3-30
w3m
Debian:14
before 0.5.3-30
0.5.3-30
w3m
Mageia:5
From an advisory covering 34 CVEs
before 0.5.3-8.2.mga5
0.5.3-8.2.mga5
w3m
SUSE:Linux Enterprise Server 11 SP4
From an advisory covering 28 CVEs
before 0.5.3.git20161120-4.1
0.5.3.git20161120-4.1
w3m
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
From an advisory covering 28 CVEs
before 0.5.3.git20161120-4.1
0.5.3.git20161120-4.1
w3m
Ubuntu:14.04:LTS
before 0.5.3-15ubuntu0.1, plus listed versions
0.5.3-110.5.3-120.5.3-130.5.3-15
0.5.3-15ubuntu0.1
w3m
Ubuntu:16.04:LTS
before 0.5.3-26ubuntu0.1, plus listed versions
0.5.3-240.5.3-250.5.3-260.5.3-26build1
0.5.3-26ubuntu0.1
w3m
Ubuntu:14.04:LTS
From an advisory covering 33 CVEs
before 0.5.3-15ubuntu0.1, plus listed versions
0.5.3-110.5.3-120.5.3-130.5.3-15
0.5.3-15ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9422 is a high vulnerability (CVSS 8.8) in Tats W3m, published December 7, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.18%, the 88th percentile. Fixed in w3m 0.5.3-30.

References

Show 100 moreShow less
MoveEnter Open