CVE-2018-9234
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an...
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
CVE-2018-9234- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-320
- Updated
- 2026-11-02
CVE List No score
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
CVE-2018-9234- Updated
- 2026-11-02
EUVDEUVD-2018-20828 No score
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
EUVD-2018-20828- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mq99-p8pq-jp4q
7.5
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an...
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
GHSA-mq99-p8pq-jp4q- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSV
7.5
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
CVE-2018-9234- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-9234
7.5
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
DEBIAN-CVE-2018-9234- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2018-9234
7.5
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.
- Record
UBUNTU-CVE-2018-9234- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVMGASA-2018-0254 No score
Updated gnupg2 packages fix security vulnerability
GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey. (CVE-2018-9234)
- Record
MGASA-2018-0254- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10815-1 No score
dirmngr-2.2.27-2.4 on GA media
These are all security issues fixed in the dirmngr-2.2.27-2.4 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10815-1- Updated
- 2026-11-02
OSVSUSE-SU-2023:3857-1 No score
Security update for gpg2
This update for gpg2 fixes the following issues:
- CVE-2018-9234: Fixed unenforced configuration allows for apparently valid certifications actually signed by signing subkeys (bsc#1088255).
- Record
SUSE-SU-2023:3857-1- Updated
- 2026-11-02
OSVUSN-3675-1 No score
gnupg, gnupg2 vulnerabilities
Marcus Brinkmann discovered that during decryption or verification, GnuPG did not properly filter out terminal sequences when reporting the original filename. An attacker could use this to specially craft a file that would cause an application parsing GnuPG output to incorrectly interpret the status of the cryptographic operation reported by GnuPG. (CVE-2018-12020)
Lance Vick discovered that GnuPG did not enforce configurations where key certification required an offline primary Certify key. An attacker with access to a signing subkey could generate certifications that appeared to be valid. This issue only affected Ubuntu 18.04 LTS. (CVE-2018-9234)
- Record
USN-3675-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gnupg2Debian:12 |
before 2.2.7-1 | 2.2.7-1 |
gnupg2Debian:13 |
before 2.2.7-1 | 2.2.7-1 |
gnupg2Debian:14 |
before 2.2.7-1 | 2.2.7-1 |
gnupg2Mageia:5 |
before 2.0.27-1.1.mga5 | 2.0.27-1.1.mga5 |
gnupg2Mageia:6 |
before 2.1.21-3.mga6 | 2.1.21-3.mga6 |
gpg2SUSE:Linux Enterprise Server 12 SP5 |
before 2.0.24-9.14.1 | 2.0.24-9.14.1 |
gpg2SUSE:Linux Enterprise Server for SAP Applications 12 SP5 |
before 2.0.24-9.14.1 | 2.0.24-9.14.1 |
gnupg2Ubuntu:18.04:LTS |
before 2.2.4-1ubuntu1.1, plus listed versions 2.1.15-1ubuntu82.2.4-1ubuntu1 |
2.2.4-1ubuntu1.1 |
gnupgUbuntu:14.04:LTS From an advisory covering 2 CVEs |
before 1.4.16-1ubuntu2.5, plus listed versions 1.4.14-1ubuntu21.4.15-1.1ubuntu11.4.15-1.1ubuntu21.4.15-2ubuntu11.4.16-1ubuntu1 Show 4 moreShow less1.4.16-1ubuntu21.4.16-1ubuntu2.11.4.16-1ubuntu2.31.4.16-1ubuntu2.4 |
1.4.16-1ubuntu2.5 |
gnupgUbuntu:16.04:LTS From an advisory covering 2 CVEs |
before 1.4.20-1ubuntu3.2, plus listed versions 1.4.18-7ubuntu11.4.19-6ubuntu11.4.20-1ubuntu11.4.20-1ubuntu21.4.20-1ubuntu31.4.20-1ubuntu3.1 |
1.4.20-1ubuntu3.2 |
gnupg2Ubuntu:18.04:LTS From an advisory covering 2 CVEs |
before 2.2.4-1ubuntu1.1, plus listed versions 2.1.15-1ubuntu82.2.4-1ubuntu1 |
2.2.4-1ubuntu1.1 |
gpg2openSUSE:Tumbleweed From an advisory covering 8 CVEs |
before 2.2.27-2.4 | 2.2.27-2.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-9234 is a high vulnerability (CVSS 7.5) in Gnupg, published April 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in gnupg2 2.2.7-1.
References
dev.gnupg.org/T3844
usn.ubuntu.com/3675-1
nvd.nist.gov/vuln/detail/CVE-2018-9234
github.com/advisories/GHSA-mq99-p8pq-jp4q
security-tracker.debian.org/tracker/CVE-2018-9234
advisories.mageia.org/MGASA-2018-0254.html
Show 15 moreShow less
bugs.mageia.org/show_bug.cgi?id=22940
suse.com/support/update/announcement/2023/suse-su-20233857-1
bugzilla.suse.com/1088255
suse.com/security/cve/CVE-2018-9234
ubuntu.com/security/CVE-2018-9234
ubuntu.com/security/notices/USN-3675-1
cve.org/CVERecord?id=CVE-2018-9234
ubuntu.com/security/CVE-2018-12020
suse.com/security/cve/CVE-2006-0455
suse.com/security/cve/CVE-2006-3746
suse.com/security/cve/CVE-2006-6169
suse.com/security/cve/CVE-2008-1530
suse.com/security/cve/CVE-2018-12020
suse.com/security/cve/CVE-2019-14855
suse.com/security/cve/CVE-2020-25125