CVE-2018-18718
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the...
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
CVE-2018-18718- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-415
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
CVE-2018-18718- Updated
- 2026-11-02
EUVDEUVD-2018-10434 No score
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
EUVD-2018-10434- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rr89-xjwm-mp65
7.8
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the...
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
GHSA-rr89-xjwm-mp65- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
OSV
7.8
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
CVE-2018-18718- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-18718
7.8
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
DEBIAN-CVE-2018-18718- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2018-18718
7.8
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer.
- Record
UBUNTU-CVE-2018-18718- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0039 No score
Updated gthumb packages fix security vulnerability
An issue was discovered in gThumb through 3.6.2. There is a double-free vulnerability in the add_themes_from_dir method in dlg-contact-sheet.c because of two successive calls of g_free, each of which frees the same buffer. (CVE-2018-18718)
- Record
MGASA-2019-0039- Updated
- 2026-11-02
OSVopenSUSE-SU-2019:0022-1 No score
Security update for gthumb
This update for gthumb fixes the following issues:
Security issue fixed:
- CVE-2018-18718: Fixed a double-free in add_themes_from_dir function from dlg-contact-sheet.c (boo#1113749)
- Record
openSUSE-SU-2019:0022-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10832-1 No score
gthumb-3.12.0-3.1 on GA media
These are all security issues fixed in the gthumb-3.12.0-3.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10832-1- Updated
- 2026-11-02
OSVUSN-5681-1 No score
gThumb vulnerabilities
It was discovered that gThumb did not properly managed memory under certain circumstances. An attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-18718)
It was discovered that gThumb did not properly managed memory when processing certain image files. If a user were tricked into opening a specially crafted JPEG file, an attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2019-20326)
It was discovered that gThumb did not properly handled certain malformed image files. If a user were tricked into opening a specially crafted JPEG file, an attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service. (CVE-2020-36427)
- Record
USN-5681-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gthumbDebian:12 |
before 3:3.6.2-2 | 3:3.6.2-2 |
gthumbDebian:13 |
before 3:3.6.2-2 | 3:3.6.2-2 |
gthumbDebian:14 |
before 3:3.6.2-2 | 3:3.6.2-2 |
gthumbDebian:8 |
before 3:3.3.1-2.1+deb8u1, plus listed versions 3:3.3.1-2 |
3:3.3.1-2.1+deb8u1 |
gthumbMageia:6 |
before 3.4.5-2.1.mga6 | 3.4.5-2.1.mga6 |
gthumbUbuntu:Pro:16.04:LTS |
before 3:3.4.3-1ubuntu0.1~esm1, plus listed versions 3:3.3.1.is.3.2.8-0ubuntu33:3.4.1-23:3.4.1-33:3.4.1-43:3.4.3-1 |
3:3.4.3-1ubuntu0.1~esm1 |
gthumbUbuntu:Pro:18.04:LTS |
before 3:3.6.1-1ubuntu0.1~esm1, plus listed versions 3:3.5.2-2ubuntu13:3.5.3-13:3.5.4-13:3.6.0-13:3.6.0-23:3.6.0-33:3.6.0-43:3.6.1-1 |
3:3.6.1-1ubuntu0.1~esm1 |
gthumbUbuntu:Pro:16.04:LTS From an advisory covering 3 CVEs |
before 3:3.4.3-1ubuntu0.1~esm1, plus listed versions 3:3.3.1.is.3.2.8-0ubuntu33:3.4.1-23:3.4.1-33:3.4.1-43:3.4.3-1 |
3:3.4.3-1ubuntu0.1~esm1 |
gthumbUbuntu:Pro:18.04:LTS From an advisory covering 3 CVEs |
before 3:3.6.1-1ubuntu0.1~esm1, plus listed versions 3:3.5.2-2ubuntu13:3.5.3-13:3.5.4-13:3.6.0-13:3.6.0-23:3.6.0-33:3.6.0-43:3.6.1-1 |
3:3.6.1-1ubuntu0.1~esm1 |
gthumbSUSE:Package Hub 15 |
before 3.6.1-bp150.2.3.1 | 3.6.1-bp150.2.3.1 |
gthumbopenSUSE:Leap 15.0 |
before 3.6.1-bp150.2.3.1 | 3.6.1-bp150.2.3.1 |
gthumbopenSUSE:Tumbleweed |
before 3.12.0-3.1 | 3.12.0-3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-18718 is a high vulnerability (CVSS 7.8) in Gnome Gthumb, published October 28, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 35th percentile. Fixed in gthumb 3:3.6.2-2.
References
gitlab.gnome.org/GNOME/gthumb/issues/18
lists.debian.org/debian-lts-announce/2018/11/msg00002.html
nvd.nist.gov/vuln/detail/CVE-2018-18718
github.com/advisories/GHSA-rr89-xjwm-mp65
security-tracker.debian.org/tracker/CVE-2018-18718
advisories.mageia.org/MGASA-2019-0039.html
Show 10 moreShow less
bugs.mageia.org/show_bug.cgi?id=24183
lists.opensuse.org/opensuse-updates/2019-01/msg00031.html
ubuntu.com/security/CVE-2018-18718
ubuntu.com/security/notices/USN-5681-1
cve.org/CVERecord?id=CVE-2018-18718
ubuntu.com/security/CVE-2019-20326
ubuntu.com/security/CVE-2020-36427
lists.opensuse.org/archives/list/[email protected]/thread/O4WV5JRRJVJABTNS6APONDONJQM5NPYG
bugzilla.suse.com/1113749
suse.com/security/cve/CVE-2018-18718