Every CVE Search/ Get API key

CVE-2017-12194

A flaw was found in the way spice-client processed certain messages sent from the server. An...

9.8 CriticalFix available

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.25%Up 3.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
CVE-2017-12194
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-121, CWE-20
Updated
2026-11-02
CVE List No score

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
CVE-2017-12194
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2017-3769 No score

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
EUVD-2017-3769
Updated
2026-11-03
GitHub AdvisoriesGHSA-r5rv-8pm6-w5ch 9.8

A flaw was found in the way spice-client processed certain messages sent from the server. An...

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
GHSA-r5rv-8pm6-w5ch
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 9.8

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
CVE-2017-12194
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-12194 9.8

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
DEBIAN-CVE-2017-12194
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-12194 9.8

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Record
UBUNTU-CVE-2017-12194
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0099 No score

Updated spice-gtk packages fix security vulnerability

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable. (CVE-2017-12194)

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts. (CVE-2018-10873)

Multiple integer overflow and buffer overflow issues were discovered in spice-client's handling of LZ compressed frames. A malicious server could cause the client to crash or, potentially, execute arbitrary code. (CVE-2018-10893)

Record
MGASA-2019-0099
Updated
2026-11-02
OSVSUSE-SU-2018:0877-1 No score

Security update for spice-gtk

This update for spice-gtk fixes the following issues:

  • CVE-2017-12194: A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable. (bsc#1085415)
Record
SUSE-SU-2018:0877-1
Updated
2026-11-02
OSVUSN-3659-1 No score

spice, spice-protocol vulnerability

Frediano Ziglio discovered that Spice incorrectly handled certain client messages. An attacker could possibly use this to cause Spice to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-3659-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
spice-gtk
Debian:12
before 0.35-1
0.35-1
spice-gtk
Debian:13
before 0.35-1
0.35-1
spice-gtk
Debian:14
before 0.35-1
0.35-1
spice-gtk
Mageia:6
before 0.33-3.1.mga6
0.33-3.1.mga6
spice-gtk
SUSE:Linux Enterprise Desktop 12 SP3
before 0.33-3.3.2
0.33-3.3.2
spice-gtk
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 0.33-3.3.2
0.33-3.3.2
spice-gtk
SUSE:Linux Enterprise Server 12 SP3
before 0.33-3.3.2
0.33-3.3.2
spice-gtk
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 0.33-3.3.2
0.33-3.3.2
spice
Ubuntu:14.04:LTS
before 0.12.4-0nocelt2ubuntu1.6, plus listed versions
0.12.4-0nocelt10.12.4-0nocelt1.10.12.4-0nocelt1.1ubuntu10.12.4-0nocelt20.12.4-0nocelt2ubuntu1
Show 5 moreShow less
0.12.4-0nocelt2ubuntu1.10.12.4-0nocelt2ubuntu1.20.12.4-0nocelt2ubuntu1.30.12.4-0nocelt2ubuntu1.40.12.4-0nocelt2ubuntu1.5
0.12.4-0nocelt2ubuntu1.6
spice-protocol
Ubuntu:16.04:LTS
before 0.12.10-1ubuntu0.1, plus listed versions
0.12.7-10.12.10-1
0.12.10-1ubuntu0.1
spice
Ubuntu:18.04:LTS
before 0.14.0-1ubuntu2.1, plus listed versions
0.12.8-2.20.14.0-10.14.0-1ubuntu10.14.0-1ubuntu2
0.14.0-1ubuntu2.1
spice-gtk
Ubuntu:18.04:LTS
All versions, plus listed versions
0.33-3.30.34-1.10.34-1.1build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12194 is a critical vulnerability (CVSS 9.8) in Freedesktop.org Spice-gtk, published March 14, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.25%, the 92nd percentile. Fixed in spice-gtk 0.35-1.

References

Show 13 moreShow less
MoveEnter Open