Every CVE Search/ Get API key

CVE-2018-1000100

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia...

7.8 HighFix available

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.09%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Record
CVE-2018-1000100
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Record
CVE-2018-1000100
Updated
2026-11-02
EUVDEUVD-2018-1838 No score

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Record
EUVD-2018-1838
Updated
2026-11-03
GitHub AdvisoriesGHSA-63xh-fh87-9c7q 7.8

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia...

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Record
GHSA-63xh-fh87-9c7q
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 7.8

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Record
CVE-2018-1000100
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-1000100 7.8

GPAC MP4Box version 0.7.1 and earlier contains a Buffer Overflow vulnerability in src/isomedia/avc_ext.c lines 2417 to 2420 that can result in Heap chunks being modified, this could lead to RCE. This attack appear to be exploitable via an attacker supplied MP4 file that when run by the victim may result in RCE.

Record
UBUNTU-CVE-2018-1000100
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0146 No score

Updated gpac packages fix security vulnerability

It was discovered that the GPAC MP4Box utility incorrectly handled certain memory operations. If an user or automated system were tricked into opening a specially crafted MP4 file, a remote attacker could use this issue to cause MP4Box to crash, resulting in a denial of service, or possibly execute arbitrary code (CVE-2018-7752, CVE-2018-13005, CVE-2018-13006, CVE-2018-20760, CVE-2018-20761, CVE-2018-20762, CVE-2018-20763, CVE-2018-1000100).

Record
MGASA-2019-0146
Updated
2026-11-02
OSVUSN-3926-1 No score

gpac vulnerabilities

It was discovered that the GPAC MP4Box utility incorrectly handled certain memory operations. If an user or automated system were tricked into opening a specially crafted MP4 file, a remote attacker could use this issue to cause MP4Box to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-3926-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpac
Mageia:6
From an advisory covering 8 CVEs
before 0.6.1-4.1.mga6.tainted
0.6.1-4.1.mga6.tainted
gpac
Ubuntu:Pro:14.04:LTS
before 0.5.0+svn4288~dfsg1-4ubuntu1+esm1, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu1
0.5.0+svn4288~dfsg1-4ubuntu1+esm1
gpac
Ubuntu:16.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
gpac
Ubuntu:18.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-3
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
gpac
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-50.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
None known
gpac
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-22.0.0+dfsg1-2ubuntu0.1~esm2
None known
gpac
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build22.2.1+dfsg1-3.1ubuntu0.1~esm2
None known
gpac
Ubuntu:16.04:LTS
From an advisory covering 8 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
gpac
Ubuntu:18.04:LTS
From an advisory covering 8 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-3
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1000100 is a high vulnerability (CVSS 7.8) in Gpac Project Gpac, published March 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in gpac 0.5.0+svn4288~dfsg1-4ubuntu1+esm1.

References

Show 10 moreShow less
MoveEnter Open