CVE-2022-41322
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can...
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
CVE-2022-41322- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
CVE List
7.8
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
CVE-2022-41322- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
EUVDEUVD-2022-44530
7.8
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
EUVD-2022-44530- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5v8v-cp6r-mq7c
7.8
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can...
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
GHSA-5v8v-cp6r-mq7c- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
OSV
7.8
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
CVE-2022-41322- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-41322
7.8
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
UBUNTU-CVE-2022-41322- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-41322 No score
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
- Record
DEBIAN-CVE-2022-41322- Updated
- 2026-11-03
OSVMGASA-2022-0364 No score
Updated kitty packages fix security vulnerability
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup. (CVE-2022-41322)
- Record
MGASA-2022-0364- Updated
- 2026-11-02
OSVUSN-5659-1 No score
kitty vulnerabilities
Stephane Chauveau discovered that kitty incorrectly handled image filenames with special characters in error messages. A remote attacker could possibly use this to execute arbitrary commands. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-35605)
Carter Sande discovered that kitty incorrectly handled escape sequences in desktop notifications. A remote attacker could possibly use this to execute arbitrary commands. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-41322)
- Record
USN-5659-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kittyDebian:12 |
before 0.21.2-2 | 0.21.2-2 |
kittyDebian:13 |
before 0.21.2-2 | 0.21.2-2 |
kittyDebian:14 |
before 0.21.2-2 | 0.21.2-2 |
kittyDebian:11 |
before 0.19.3-1+deb11u1, plus listed versions 0.19.3-1 |
0.19.3-1+deb11u1 |
kittyMageia:8 |
before 0.26.3-1.mga8 | 0.26.3-1.mga8 |
kittyUbuntu:22.04:LTS |
before 0.21.2-1ubuntu0.22.04.1, plus listed versions 0.19.3-10.21.2-10.21.2-1build1 |
0.21.2-1ubuntu0.22.04.1 |
kittyUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 0.15.0-1ubuntu0.2, plus listed versions 0.14.3-10.14.4-10.14.6-10.15.0-10.15.0-1build1 |
0.15.0-1ubuntu0.2 |
kittyUbuntu:22.04:LTS From an advisory covering 2 CVEs |
before 0.21.2-1ubuntu0.22.04.1, plus listed versions 0.19.3-10.21.2-10.21.2-1build1 |
0.21.2-1ubuntu0.22.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-41322 is a high vulnerability (CVSS 7.8) in Kitty Project Kitty, published September 23, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in kitty 0.21.2-2.
References
github.com/kovidgoyal/kitty/commit/f05783e64d5fa62e1aed603e8d69aced5e49824f
bugs.gentoo.org/868543
github.com/kovidgoyal/kitty/compare/v0.26.1...v0.26.2
sw.kovidgoyal.net/kitty/changelog
security.gentoo.org/glsa/202209-22
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6RRNAPU33PHEH64P77YL3AJO6CTZGHTX
Show 15 moreShow less
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/47RK7MBSVY5BWDUTYMJUFPBAYFSWMTOI
lists.debian.org/debian-lts-announce/2025/06/msg00000.html
nvd.nist.gov/vuln/detail/CVE-2022-41322
lists.fedoraproject.org/archives/list/[email protected]/message/47RK7MBSVY5BWDUTYMJUFPBAYFSWMTOI
lists.fedoraproject.org/archives/list/[email protected]/message/6RRNAPU33PHEH64P77YL3AJO6CTZGHTX
github.com/advisories/GHSA-5v8v-cp6r-mq7c
github.com/CVEProject/cvelistV5/tree/main/cves/2022/41xxx/CVE-2022-41322.json
security-tracker.debian.org/tracker/CVE-2022-41322
advisories.mageia.org/MGASA-2022-0364.html
bugs.mageia.org/show_bug.cgi?id=30930
lists.fedoraproject.org/archives/list/[email protected]/thread/47RK7MBSVY5BWDUTYMJUFPBAYFSWMTOI
ubuntu.com/security/CVE-2022-41322
ubuntu.com/security/notices/USN-5659-1
cve.org/CVERecord?id=CVE-2022-41322
ubuntu.com/security/CVE-2020-35605