Every CVE Search/ Get API key

CVE-2020-36430

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from...

7.8 HighFix available

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.08%Up 0.3 points since Jul 20, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
CVE-2020-36430
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
CVE-2020-36430
Updated
2026-11-02
EUVDEUVD-2020-23958 No score

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
EUVD-2020-23958
Updated
2026-11-03
GitHub AdvisoriesGHSA-pqvw-6c6x-gvwh 7.8

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from...

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
GHSA-pqvw-6c6x-gvwh
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
CVE-2020-36430
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-36430 7.8

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
DEBIAN-CVE-2020-36430
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVOESA-2021-1303 7.8

libass security update

libass is a portable subtitle renderer for the ASS/SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. It is mostly compatible with VSFilter.

Security Fix(es):

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.(CVE-2020-36430)

Record
OESA-2021-1303
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-36430 7.8

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction.

Record
UBUNTU-CVE-2020-36430
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2021-0413 No score

Updated libass packages fix security vulnerability

Updated libass packages fix security vulnerability:

libass 0.15.x before 0.15.1 has a heap-based buffer overflow in decode_chars (called from decode_font and process_text) because the wrong integer data type is used for subtraction (CVE-2020-36430).

Record
MGASA-2021-0413
Updated
2026-11-02
OSVopenSUSE-SU-2021:1174-1 No score

Security update for libass

This update for libass fixes the following issues:

  • CVE-2020-36430: Fixed heap-based buffer overflow in decode_chars (bsc#1188539).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2021:1174-1
Updated
2026-11-02
OSVopenSUSE-SU-2021:2792-1 No score

Security update for libass

This update for libass fixes the following issues:

  • CVE-2020-36430: Fixed heap-based buffer overflow in decode_chars (bsc#1188539).
Record
openSUSE-SU-2021:2792-1
Updated
2026-11-02
OSVSUSE-SU-2021:2792-1 No score

Security update for libass

This update for libass fixes the following issues:

  • CVE-2020-36430: Fixed heap-based buffer overflow in decode_chars (bsc#1188539).
Record
SUSE-SU-2021:2792-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libass
Debian:12
before 1:0.15.0-2
1:0.15.0-2
libass
Debian:13
before 1:0.15.0-2
1:0.15.0-2
libass
Debian:14
before 1:0.15.0-2
1:0.15.0-2
libass
Mageia:8
before 0.15.1-1.mga8
0.15.1-1.mga8
libass
openEuler:20.03-LTS-SP2
before 0.15.0-2.oe1
0.15.0-2.oe1
libass
SUSE:Linux Enterprise Module for Desktop Applications 15 SP2
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise Module for Desktop Applications 15 SP3
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise High Performance Computing 15-ESPOS
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise High Performance Computing 15-LTSS
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS
before 0.14.0-3.9.1
0.14.0-3.9.1
Show 12 moreShow less
Affected packages
PackageAffectedFixed
libass
SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise Server 15-LTSS
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise Server 15 SP1-BCL
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise Server 15 SP1-LTSS
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise Server for SAP Applications 15
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Linux Enterprise Server for SAP Applications 15 SP1
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Manager Proxy 4.0
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Manager Retail Branch Server 4.0
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Manager Server 4.0
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
SUSE:Enterprise Storage 6
before 0.14.0-3.9.1
0.14.0-3.9.1
libass
openSUSE:Leap 15.2
before 0.14.0-lp152.4.9.1
0.14.0-lp152.4.9.1
libass
openSUSE:Leap 15.3
before 0.14.0-3.9.1
0.14.0-3.9.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-36430 is a high vulnerability (CVSS 7.8) in Libass Project Libass, published July 20, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in libass 1:0.15.0-2.

References

Show 14 moreShow less
MoveEnter Open