Every CVE Search/ Get API key

CVE-2021-3623

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets...

6.1 MediumFix available

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
High

Exploit likelihood

0.32%Down 0.6 points since Mar 3, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
CVE-2021-3623
CVSS 3.1
6.1 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
CVSS 2.0
3.6 LowAV:L/AC:L/Au:N/C:P/I:N/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
CVE-2021-3623
Weakness
CWE-787
Updated
2026-11-02
EUVDEUVD-2021-26926 No score

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
EUVD-2021-26926
Updated
2026-11-03
GitHub AdvisoriesGHSA-6527-9qhc-39j4 8.2

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets...

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
GHSA-6527-9qhc-39j4
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 6.1

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
CVE-2021-3623
CVSS 3.1
6.1 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-3623 6.1

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
DEBIAN-CVE-2021-3623
CVSS 3.1
6.1 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVOESA-2022-1695 8.2

libtpms security update

A library providing TPM functionality for VMs. Targeted for integration into Qemu.

Security Fix(es):

A flaw was found in the libtpms code that may cause access beyond the boundary of internal buffers. The vulnerability is triggered by specially-crafted TPM2 command packets that then trigger the issue when the state of the TPM2's volatile state is written. The highest threat from this vulnerability is to system availability. This issue affects libtpms versions before 0.8.5, before 0.7.9 and before 0.6.6.(CVE-2021-3746)

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.(CVE-2021-3623)

Record
OESA-2022-1695
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-3623 6.1

A flaw was found in libtpms. The flaw can be triggered by specially-crafted TPM 2 command packets containing illegal values and may lead to an out-of-bounds access when the volatile state of the TPM 2 is marshalled/written or unmarshalled/read. The highest threat from this vulnerability is to system availability.

Record
UBUNTU-CVE-2021-3623
CVSS 3.1
6.1 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
Updated
2026-11-02
OSVMGASA-2021-0590 No score

Updated libtpms/swtpm packages fix security vulnerability

CryptSym: fix AES output IV (CVE-2021-3505). Fixed a context save and suspend/resume problem when public keys are loaded. Reset too large size indicators in TPM2B to avoid access beyond buffer (CVE-2021-3623) Restore original value in buffer if unmarshalled one was illegal Fixed out-of-bounds access via specially crafted TPM 2 command packets (CVE-2021-3746) Marshal event sequence objects' hash state

Record
MGASA-2021-0590
Updated
2026-11-02
OSVopenSUSE-SU-2024:12445-1 No score

libtpms-devel-0.9.3-2.1 on GA media

These are all security issues fixed in the libtpms-devel-0.9.3-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12445-1
Updated
2026-11-02
OSVSUSE-SU-2022:4457-1 No score

Security update for libtpms

This update for libtpms fixes the following issues:

  • CVE-2021-3623: Fixed out-of-bounds access when trying to resume the state of the vTPM (bsc#1187767)
Record
SUSE-SU-2022:4457-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libtpms
Debian:12
before 0.9.1-1
0.9.1-1
libtpms
Debian:13
before 0.9.1-1
0.9.1-1
libtpms
Debian:14
before 0.9.1-1
0.9.1-1
libtpms
Mageia:8
before 0.9.1-1.mga8
0.9.1-1.mga8
swtpm
Mageia:8
before 0.7.0-5.mga8
0.7.0-5.mga8
libtpms
openEuler:20.03-LTS-SP1
before 0.7.3-7.oe1
0.7.3-7.oe1
libtpms
openEuler:20.03-LTS-SP3
before 0.7.3-7.oe1
0.7.3-7.oe1
libtpms
openEuler:22.03-LTS
before 0.7.3-7.oe2203
0.7.3-7.oe2203
libtpms
SUSE:Linux Enterprise Micro 5.3
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
SUSE:Linux Enterprise Module for Server Applications 15 SP3
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
libtpms
SUSE:Linux Enterprise Module for Server Applications 15 SP4
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
SUSE:Linux Enterprise Micro 5.1
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
SUSE:Linux Enterprise Micro 5.2
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
openSUSE:Leap Micro 5.2
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
openSUSE:Leap Micro 5.3
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
openSUSE:Leap 15.3
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1
libtpms
openSUSE:Leap 15.4
before 0.8.2-150300.3.6.1
0.8.2-150300.3.6.1

History

History
RecordedChangedSources
affected
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3623 is a medium vulnerability (CVSS 6.1) in Libtpms Project Libtpms, published December 30, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 25th percentile. Fixed in libtpms 0.9.1-1.

References

Show 22 moreShow less
MoveEnter Open