Every CVE Search/ Get API key

CVE-2021-33454

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in...

5.5 MediumFix available

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.34%Down 0.5 points since Jul 27, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
CVE-2021-33454
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
CVE-2021-33454
Updated
2026-11-02
EUVDEUVD-2021-20158 No score

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
EUVD-2021-20158
Updated
2026-11-03
GitHub AdvisoriesGHSA-xc6r-vpp5-48cq 5.5

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in...

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
GHSA-xc6r-vpp5-48cq
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVAZL-10324 5.5

CVE-2021-33454 affecting package yasm for versions less than 1.3.0-15

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
AZL-10324
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVAZL-35364 5.5

CVE-2021-33454 affecting package yasm for versions less than 1.3.0-15

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
AZL-35364
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-05
Show 6 moreShow less
OSV 5.5

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
CVE-2021-33454
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-33454 5.5

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
DEBIAN-CVE-2021-33454
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVJLSEC-2026-584 5.5

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
JLSEC-2026-584
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVOESA-2025-1526 5.5

yasm security update

Yasm is a complete rewrite of the NASM assembler under the “new” BSD License.

Security Fix(es):

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.(CVE-2021-33454)

An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.(CVE-2021-33464)

yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.(CVE-2023-29579)

Record
OESA-2025-1526
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-33454 5.5

An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.

Record
UBUNTU-CVE-2021-33454
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVROOT-OS-ALPINE-318-CVE-2021-33454 No score

CVE-2021-33454 in yasm - Patched by Root

Root has patched CVE-2021-33454 in the yasm package for Root:Alpine:3.18. Multiple fixed versions available.

Record
ROOT-OS-ALPINE-318-CVE-2021-33454
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
yasm
Azure Linux:2
before 1.3.0-15
1.3.0-15
yasm
Azure Linux:3
before 1.3.0-15
1.3.0-15
yasm
Debian:12
All versions, plus listed versions
1.3.0-41.3.0-51.3.0-61.3.0-71.3.0-8
None known
yasm
Debian:13
All versions, plus listed versions
1.3.0-71.3.0-8
None known
yasm
Debian:14
All versions, plus listed versions
1.3.0-71.3.0-8
None known
YASM_jll
Julia
All versions None known
yasm
openEuler:24.03-LTS-SP1
From an advisory covering 3 CVEs
before 1.3.0-13.oe2403sp1
1.3.0-13.oe2403sp1
yasm
openEuler:20.03-LTS-SP4
From an advisory covering 3 CVEs
before 1.3.0-13.oe2003sp4
1.3.0-13.oe2003sp4
yasm
openEuler:22.03-LTS-SP3
From an advisory covering 3 CVEs
before 1.3.0-13.oe2203sp3
1.3.0-13.oe2203sp3
yasm
openEuler:22.03-LTS-SP4
From an advisory covering 3 CVEs
before 1.3.0-13.oe2203sp4
1.3.0-13.oe2203sp4
Show 11 moreShow less
Affected packages
PackageAffectedFixed
yasm
openEuler:24.03-LTS
From an advisory covering 3 CVEs
before 1.3.0-13.oe2403
1.3.0-13.oe2403
yasm
Root:Alpine:3.18
before 1.3.0-r40071
1.3.0-r400711.3.0-r400731.3.0-r400721.3.0-r400741.3.0-r40075
rootio-yasm
Root:Alpine:3.18
before 1.3.0-r40071
1.3.0-r400711.3.0-r400731.3.0-r400721.3.0-r400741.3.0-r40075
yasm
Ubuntu:16.04:LTS
All versions, plus listed versions
1.3.0-2
None known
yasm
Ubuntu:18.04:LTS
All versions, plus listed versions
1.3.0-21.3.0-2build1
None known
yasm
Ubuntu:20.04:LTS
All versions, plus listed versions
1.3.0-2build11.3.0-2ubuntu1
None known
yasm
Ubuntu:22.04:LTS
All versions, plus listed versions
1.3.0-2.1
None known
yasm
Ubuntu:24.04:LTS
All versions, plus listed versions
1.3.0-4
None known
yasm
Ubuntu:25.10
All versions, plus listed versions
1.3.0-51.3.0-7
None known
yasm
Ubuntu:26.10
All versions, plus listed versions
1.3.0-8
None known
yasm
Ubuntu:26.04:LTS
All versions, plus listed versions
1.3.0-71.3.0-8
None known

History

History
RecordedChangedSources
affected
factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-33454 is a medium vulnerability (CVSS 5.5) in Tortall Yasm, published July 26, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in yasm 1.3.0-15.

References

Show 4 moreShow less
MoveEnter Open