Every CVE Search/ Get API key

CVE-2006-2458

Libextractor multiple heap-based buffer overflows

4.0 MediumPublic exploitFix available

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Exploit likelihood

9.21%Down 30.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
CVE-2006-2458
CVSS 2.0
4.0 MediumAV:N/AC:H/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
CVE-2006-2458
Updated
2026-11-02
EUVDEUVD-2006-0008 No score

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
EUVD-2006-0008
Updated
2026-11-03
GitHub AdvisoriesGHSA-f836-7jqw-3684 No score

Libextractor multiple heap-based buffer overflows

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
GHSA-f836-7jqw-3684
Updated
2026-11-02
OSV No score

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
CVE-2006-2458
Updated
2026-11-02
OSVDEBIAN-CVE-2006-2458 No score

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
DEBIAN-CVE-2006-2458
Updated
2026-11-02
OSVGHSA-f836-7jqw-3684 No score

Libextractor multiple heap-based buffer overflows

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
GHSA-f836-7jqw-3684
Updated
2026-11-02
OSVPYSEC-2006-4 No score

Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).

Record
PYSEC-2006-4
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
extractor
PyPI
0.5 to 0.5 None known
libextractor
Debian:12
before 0.5.14-1
0.5.14-1
libextractor
Debian:13
before 0.5.14-1
0.5.14-1
libextractor
Debian:14
before 0.5.14-1
0.5.14-1
libextractor
Debian:3.1
before 0.4.2-2sarge5, plus listed versions
0.4.2-20.4.2-2sarge10.4.2-2sarge20.4.2-2sarge30.4.2-2sarge4
0.4.2-2sarge5
extractor
PyPI
Listed versions
0.5
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBlibextractor 0.5.13 - Multiple Heap Overflows (PoC)2006-05-17

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2006-2458 is a medium vulnerability (CVSS 4.0) in Libextractor, published May 18, 2006. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 9.21%, the 95th percentile. Fixed in libextractor 0.5.14-1.

References

Show 13 moreShow less
MoveEnter Open