Every CVE Search/ Get API key

CVE-2010-0669

MoinMoin improper sanitizes user profiles

7.5 HighFix available

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Exploit likelihood

1.90%Up 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Record
CVE-2010-0669
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Record
CVE-2010-0669
Updated
2026-11-02
EUVDEUVD-2010-0009 No score

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Record
EUVD-2010-0009
Updated
2026-11-03
GitHub AdvisoriesGHSA-977v-29j9-9rxc No score

MoinMoin improper sanitizes user profiles

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Record
GHSA-977v-29j9-9rxc
Updated
2026-11-02
OSVGHSA-977v-29j9-9rxc No score

MoinMoin improper sanitizes user profiles

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Record
GHSA-977v-29j9-9rxc
Updated
2026-11-02
OSVPYSEC-2010-2 No score

MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.

Record
PYSEC-2010-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moin
PyPI
before 1.8.7
1.8.7
moin
PyPI
1.9 up to 1.9.2
1.9.2
moin
Debian:5.0
before 1.7.1-3+lenny3, plus listed versions
1.7.1-3+lenny11.7.1-3+lenny2
1.7.1-3+lenny3
moin
PyPI
before 1.8.7, plus listed versions
1.8.41.8.51.8.6
1.8.7
moin
PyPI
1.9 up to 1.9.2, plus listed versions
1.9.01.9.1
1.9.2
moin
PyPI
before 1.8.7, 1.9 up to 1.9.2, plus listed versions
1.8.41.8.51.8.61.9.01.9.1
1.8.71.9.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-0669 is a high vulnerability (CVSS 7.5) in Moinmo Moinmoin, published February 26, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.90%, the 79th percentile. Fixed in moin 1.8.7.

References

Show 12 moreShow less
MoveEnter Open