Every CVE Search/ Get API key

CVE-2013-1629

Improper Input Validation in pip

6.8 MediumFix available

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Exploit likelihood

6.19%Up 3.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
CVE-2013-1629
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
CVE-2013-1629
Updated
2026-11-02
EUVDEUVD-2013-0025 No score

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
EUVD-2013-0025
Updated
2026-11-03
GitHub AdvisoriesGHSA-g3p5-fjj9-h8gj 7.3

Improper Input Validation in pip

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
GHSA-g3p5-fjj9-h8gj
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
CVSS 3.1
8.4 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-g3p5-fjj9-h8gj 7.3

Improper Input Validation in pip

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
GHSA-g3p5-fjj9-h8gj
CVSS 4.0
7.3 HighCVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
CVSS 3.1
8.4 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV No score

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
CVE-2013-1629
Updated
2026-11-02
OSVDEBIAN-CVE-2013-1629 No score

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
DEBIAN-CVE-2013-1629
Updated
2026-11-02
OSVPYSEC-2013-8 No score

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
PYSEC-2013-8
Updated
2026-11-02
OSVUBUNTU-CVE-2013-1629 No score

pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.

Record
UBUNTU-CVE-2013-1629
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pip
PyPI
before 1.3
1.3
python-pip
Debian:12
before 1.3.1-1
1.3.1-1
python-pip
Debian:13
before 1.3.1-1
1.3.1-1
python-pip
Debian:14
before 1.3.1-1
1.3.1-1
python-virtualenv
Debian:12
before 1.9.1-1
1.9.1-1
python-virtualenv
Debian:13
before 1.9.1-1
1.9.1-1
python-virtualenv
Debian:14
before 1.9.1-1
1.9.1-1
pip
PyPI
before 1.3, plus listed versions
0.20.2.10.30.3.10.4
Show 19 moreShow less
0.50.5.10.60.6.10.6.20.6.30.70.7.10.7.20.80.8.10.8.20.8.31.01.0.11.0.21.11.21.2.1
1.3

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1629 is a medium vulnerability (CVSS 6.8) in Pypa Pip, published August 6, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.19%, the 93rd percentile. Fixed in pip 1.3.

References

Show 7 moreShow less
MoveEnter Open