CVE-2014-3995
Djblets Cross-site scripting Vulnerability
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
- Record
CVE-2014-3995- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
- Record
CVE-2014-3995- Updated
- 2026-11-02
EUVDEUVD-2014-0017 No score
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
- Record
EUVD-2014-0017- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4xf6-xr96-7vmp
5.3
Djblets Cross-site scripting Vulnerability
A cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
- Record
GHSA-4xf6-xr96-7vmp- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-4xf6-xr96-7vmp
5.3
Djblets Cross-site scripting Vulnerability
A cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
- Record
GHSA-4xf6-xr96-7vmp- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVMGASA-2014-0462 No score
Updated python-djblets packages fix security vulnerabilities
Cross-site scripting (XSS) vulnerability in util/templatetags/djblets_js.py in Djblets before 0.7.30 for Django, as used in Review Board, allows remote attackers to inject arbitrary web script or HTML via a JSON object, as demonstrated by the name field when changing a user name (CVE-2014-3994).
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 Django allows remote attackers to inject arbitrary web script or HTML via a user display name (CVE-2014-3995).
- Record
MGASA-2014-0462- Updated
- 2026-11-02
OSVPYSEC-2014-79 No score
Cross-site scripting (XSS) vulnerability in gravatars/templatetags/gravatars.py in Djblets before 0.7.30 and 0.8.x before 0.8.3 for Django allows remote attackers to inject arbitrary web script or HTML via a user display name.
- Record
PYSEC-2014-79- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
djbletsPyPI |
before 0.7.30 | 0.7.30 |
djbletsPyPI |
0.8 up to 0.8.3 | 0.8.3 |
djbletsPyPI |
before 0.7.30, plus listed versions 0.50.5.10.5.20.5.30.5.4 Show 45 moreShow less0.5.50.5.60.5.70.5.80.5.90.5rc20.60.6.10.6.100.6.110.6.120.6.130.6.140.6.150.6.160.6.170.6.180.6.190.6.20.6.200.6.210.6.220.6.230.6.240.6.250.6.260.6.270.6.280.6.290.6.30.6.300.6.310.6.40.6.50.6.60.6.70.6.80.6.90.70.7.10.7.100.7.110.7.120.7.130.7.14 |
0.7.30 |
djbletsPyPI |
0.8 up to 0.8.3, plus listed versions 0.8.10.8.2 |
0.8.3 |
python-djbletsMageia:4 |
before 0.7.30-1.1.mga4 | 0.7.30-1.1.mga4 |
djbletsPyPI |
before 0.7.30, 0.8 up to 0.8.3, plus listed versions 0.50.5.10.5.20.5.30.5.4 Show 45 moreShow less0.5.50.5.60.5.70.5.80.5.90.5rc20.60.6.10.6.100.6.110.6.120.6.130.6.140.6.150.6.160.6.170.6.180.6.190.6.20.6.200.6.210.6.220.6.230.6.240.6.250.6.260.6.270.6.280.6.290.6.30.6.300.6.310.6.40.6.50.6.60.6.70.6.80.6.90.70.7.10.7.100.7.110.7.120.7.130.7.14 |
0.7.300.8.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3995 is a medium vulnerability (CVSS 4.3) in Reviewboard Djblets, published June 16, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.10%, the 81st percentile. Fixed in djblets 0.7.30.
References
seclists.org/oss-sec/2014/q2/494
seclists.org/oss-sec/2014/q2/498
github.com/djblets/djblets/commit/77ac64642ad530bf69e390c51fc6fdcb8914c8e7
secunia.com/advisories/58691
github.com/djblets/djblets/commit/e2c79117efd925636acd871a5f473512602243cf
github.com/djblets/djblets/commit/50000d0bbb983fa8c097b588d06b64df8df483bd
Show 9 moreShow less
nvd.nist.gov/vuln/detail/CVE-2014-3995
web.archive.org/web/20140702014704/http://seclists.org/oss-sec/2014/q2/498
web.archive.org/web/20140702025724/http://seclists.org/oss-sec/2014/q2/494
github.com/pypa/advisory-database/tree/main/vulns/djblets/PYSEC-2014-79.yaml
github.com/advisories/GHSA-4xf6-xr96-7vmp
github.com/djblets/djblets
advisories.mageia.org/MGASA-2014-0462.html
bugs.mageia.org/show_bug.cgi?id=13504
lists.fedoraproject.org/pipermail/package-announce/2014-June/134416.html
Left out here: 113 versions. The JSON record has them.