Every CVE Search/ Get API key

CVE-2015-5301

Ipsilon denial of service by deleting a SAML2 Service Provider (SP)

5.5 MediumFix available

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Exploit likelihood

1.49%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Record
CVE-2015-5301
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:N/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Record
CVE-2015-5301
Updated
2026-11-02
EUVDEUVD-2015-0038 No score

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Record
EUVD-2015-0038
Updated
2026-11-03
GitHub AdvisoriesGHSA-9qp4-79q8-58pr No score

Ipsilon denial of service by deleting a SAML2 Service Provider (SP)

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Record
GHSA-9qp4-79q8-58pr
Updated
2026-11-02
OSVGHSA-9qp4-79q8-58pr No score

Ipsilon denial of service by deleting a SAML2 Service Provider (SP)

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Record
GHSA-9qp4-79q8-58pr
Updated
2026-11-02
OSVPYSEC-2015-42 No score

providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).

Record
PYSEC-2015-42
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ipsilon
PyPI
0.1.0 up to 1.0.2
1.0.2
ipsilon
PyPI
1.1.0 up to 1.1.1
1.1.1
ipsilon
PyPI
1.1.0 up to 1.2.0
1.2.0

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-5301 is a medium vulnerability (CVSS 5.5) in Ipsilon Project Ipsilon, published November 17, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.49%, the 74th percentile. Fixed in ipsilon 1.0.2.

References

Show 6 moreShow less
MoveEnter Open