Every CVE Search/ Get API key

CVE-2016-9910

Cross-site Scripting in html5lib

6.1 MediumFix available

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

2.16%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
CVE-2016-9910
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
CVE-2016-9910
Updated
2026-11-02
EUVDEUVD-2017-0061 No score

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
EUVD-2017-0061
Updated
2026-11-03
GitHub AdvisoriesGHSA-8f6m-gfq9-g33v 5.3

Cross-site Scripting in html5lib

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
GHSA-8f6m-gfq9-g33v
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
CVE-2016-9910
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-9910 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
DEBIAN-CVE-2016-9910
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-8f6m-gfq9-g33v 5.3

Cross-site Scripting in html5lib

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
GHSA-8f6m-gfq9-g33v
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2016-9910 6.1

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
UBUNTU-CVE-2016-9910
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVMGASA-2017-0001 No score

Updated python-html5lib packages fix security vulnerability

Fixes a potential cross-site scripting vulnerablity: quote attributes that need escaping in legacy browsers. (CVE-2016-9909, CVE-2016-9910)

Record
MGASA-2017-0001
Updated
2026-11-02
OSVPYSEC-2017-15 No score

The serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.

Record
PYSEC-2017-15
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
html5lib
PyPI
before 0.99999999
0.99999999
html5lib
Debian:12
before 0.999999999-1
0.999999999-1
html5lib
Debian:13
before 0.999999999-1
0.999999999-1
html5lib
Debian:14
before 0.999999999-1
0.999999999-1
html5lib
PyPI
before 0.99999999, plus listed versions
0.100.110.11.10.20.9
Show 8 moreShow less
0.900.950.990.9990.99990.999990.9999990.9999999
0.99999999
python-html5lib
Mageia:5
before 1.0b3-7.1.mga5
1.0b3-7.1.mga5
html5lib
PyPI
before 0.999999999, plus listed versions
0.100.110.11.10.20.9
Show 9 moreShow less
0.900.950.990.9990.99990.999990.9999990.99999990.99999999
0.999999999
html5lib
Ubuntu:16.04:LTS
All versions, plus listed versions
0.999-3build10.999-4
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-9910 is a medium vulnerability (CVSS 6.1) in Html5lib, published January 3, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.16%, the 82nd percentile. Fixed in html5lib 0.99999999.

References

Show 12 moreShow less
MoveEnter Open