CVE-2018-20998
Potential memory corruption in arrayfire
An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.
- Record
CVE-2018-20998- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.
- Record
CVE-2018-20998- Updated
- 2026-11-02
EUVDEUVD-2019-0020 No score
An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.
- Record
EUVD-2019-0020- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-69fv-gw6g-8ccg
9.3
Potential memory corruption in arrayfire
The attribute repr() added to enums to be compatible with C-FFI caused memory corruption on MSVC toolchain.
arrayfire crates <= version 3.5.0 do not have this issue when used with Rust versions 1.27 or earlier. The issue only started to appear since Rust version 1.28.
The issue seems to be interlinked with which version of Rust is being used.
The issue was fixed in crate 3.6.0.
- Record
GHSA-69fv-gw6g-8ccg- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
9.8
An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.
- Record
CVE-2018-20998- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-69fv-gw6g-8ccg
9.3
Potential memory corruption in arrayfire
The attribute repr() added to enums to be compatible with C-FFI caused memory corruption on MSVC toolchain.
arrayfire crates <= version 3.5.0 do not have this issue when used with Rust versions 1.27 or earlier. The issue only started to appear since Rust version 1.28.
The issue seems to be interlinked with which version of Rust is being used.
The issue was fixed in crate 3.6.0.
- Record
GHSA-69fv-gw6g-8ccg- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSVRUSTSEC-2018-0011
9.8
Enum repr causing potential memory corruption
The attribute repr() added to enums to be compatible with C-FFI caused memory corruption on MSVC toolchain.
arrayfire crates <= version 3.5.0 do not have this issue when used with Rust versions 1.27 or earlier. The issue only started to appear since Rust version 1.28.
The issue seems to be interlinked with which version of Rust is being used.
The issue was fixed in crate 3.6.0.
- Record
RUSTSEC-2018-0011- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVPYSEC-2019-144 No score
An issue was discovered in the arrayfire crate before 3.6.0 for Rust. Addition of the repr() attribute to an enum is mishandled, leading to memory corruption.
- Record
PYSEC-2019-144- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
arrayfirecrates.io |
before 3.6.0 | 3.6.0 |
arrayfirePyPI |
before 3.6.0 | 3.6.0 |
arrayfirePyPI |
before 3.6.0, plus listed versions 3.0.201509143.1.201511113.2.201512113.2.201512143.2.20151224 Show 15 moreShow less3.2.20151224.post13.3.201603203.3.201603283.3.201604273.3.20160427.post13.3.201605103.3.201605163.3.201606243.3.20160624.post13.4.201609253.4.201611263.4.201702223.5.201707183.5.201707213.5.20170817 |
3.6.0 |
arrayfirecrates.io |
0.0.0-0 up to 3.6.0 | 3.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-20998 is a critical vulnerability (CVSS 9.8) in Arrayfire, published December 18, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.69%, the 77th percentile. Fixed in arrayfire 3.6.0.
References
rustsec.org/advisories/RUSTSEC-2018-0011.html
nvd.nist.gov/vuln/detail/CVE-2018-20998
github.com/arrayfire/arrayfire-rust/pull/177
github.com/pypa/advisory-database/tree/main/vulns/arrayfire/PYSEC-2019-144.yaml
github.com/arrayfire/arrayfire-rust/commit/a5256f3e5e23b83eaad69699e0b04653aba04fb8
github.com/advisories/GHSA-69fv-gw6g-8ccg
github.com/arrayfire/arrayfire-rust
crates.io/crates/arrayfire