Every CVE Search/ Get API key

CVE-2021-1725

Bot Framework SDK Information Disclosure Vulnerability

5.5 MediumFix available

Bot Framework SDK Information Disclosure Vulnerability

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.07%Down 3.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.5

Bot Framework SDK Information Disclosure Vulnerability

Bot Framework SDK Information Disclosure Vulnerability

Record
CVE-2021-1725
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C
Updated
2026-11-02
EUVDEUVD-2021-0037 5.5

Bot Framework SDK Information Disclosure Vulnerability

Record
EUVD-2021-0037
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C
Updated
2026-11-03
GitHub AdvisoriesGHSA-cqff-fx2x-p86v 8.2

botframework-connector vulnerable to Improper Authentication

Impact

A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot.

Patches

The problem has been patched in all affected versions. Please see the list of patched versions for the most appropiate one for your individual case.

Workarounds

Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if Claims are Skill Claims.

For detailed instructions, see the link in the References section.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-cqff-fx2x-p86v
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
Weakness
CWE-287
Updated
2026-11-02
GitHub AdvisoriesGHSA-fvcj-hvfw-7f2v 5.5

botframework-connector vulnerable to Improper Authentication

Impact

A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot.

Patches

The problem has been patched in all affected versions. Please see the list of patched versions for the most appropriate one for your individual case.

Workarounds

Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if the Claims are Skill Claims.

For detailed instructions, see the link in the References section.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-fvcj-hvfw-7f2v
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200, CWE-287
Updated
2026-11-02
NVD 5.5

Bot Framework SDK Information Disclosure Vulnerability

Record
CVE-2021-1725
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
OSVGHSA-cqff-fx2x-p86v 8.2

botframework-connector vulnerable to Improper Authentication

Impact

A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot.

Patches

The problem has been patched in all affected versions. Please see the list of patched versions for the most appropiate one for your individual case.

Workarounds

Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if Claims are Skill Claims.

For detailed instructions, see the link in the References section.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-cqff-fx2x-p86v
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
Weakness
CWE-287
Updated
2026-11-02
OSVGHSA-fvcj-hvfw-7f2v 5.5

botframework-connector vulnerable to Improper Authentication

Impact

A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot.

Patches

The problem has been patched in all affected versions. Please see the list of patched versions for the most appropriate one for your individual case.

Workarounds

Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if the Claims are Skill Claims.

For detailed instructions, see the link in the References section.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-fvcj-hvfw-7f2v
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200, CWE-287
Updated
2026-11-02
OSVPYSEC-2021-422 No score

Bot Framework SDK Information Disclosure Vulnerability

Record
PYSEC-2021-422
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
botframework-connector
PyPI
4.7.0 up to 4.7.2
4.7.2
botframework-connector
PyPI
4.8.0 to 4.8.0
4.8.1
botframework-connector
PyPI
4.9.0 up to 4.9.3
4.9.3
botframework-connector
PyPI
4.10.0 to 4.10.0
4.10.1
botframework-connector
npm
4.7.0 up to 4.7.3
4.7.3
botframework-connector
npm
4.8.0 to 4.8.0
4.8.1
botframework-connector
npm
4.9.0 up to 4.9.4
4.9.4
botframework-connector
npm
4.10.0 up to 4.10.3
4.10.3
botframework-connector
PyPI
4.7.0 up to 4.7.2, plus listed versions
4.7.1
4.7.2
botframework-connector
PyPI
4.8.0 up to 4.8.1
4.8.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
botframework-connector
PyPI
4.9.0 up to 4.9.3, plus listed versions
4.9.14.9.2
4.9.3
botframework-connector
PyPI
4.10.0 up to 4.10.1
4.10.1
botframework-connector
npm
4.8.0 up to 4.8.1
4.8.1
botframework-connector
PyPI
4.7.0 up to 4.7.2, 4.8.0 up to 4.8.1, 4.9.0 up to 4.9.3, 4.10.0 up to 4.10.1, plus listed versions
4.7.14.9.14.9.2
4.7.24.8.14.9.34.10.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-1725 is a medium vulnerability (CVSS 5.5) in Microsoft Bot Framework Sdk For .net Framework, published January 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 65th percentile. Fixed in botframework-connector 4.7.2.

References

Show 7 moreShow less
MoveEnter Open