CVE-2022-0845
Code Injection in pytorchlightning/pytorch-lightning
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.3
Code Injection in pytorchlightning/pytorch-lightning
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
- Record
CVE-2022-0845- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2022-0222
7.3
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
- Record
EUVD-2022-0222- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r5qj-cvf9-p85h
9.3
Code Injection in PyTorch Lightning
PyTorch Lightning version 1.5.10 and prior is vulnerable to code injection. An attacker could execute commands on the target OS running the operating system by setting the PL_TRAINER_GPUS when using the Trainer module. A patch is included in the 1.6.0 release.
- Record
GHSA-r5qj-cvf9-p85h- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
NVD
9.8
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
- Record
CVE-2022-0845- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-94
- Updated
- 2026-11-02
OSV
7.3
Code Injection in pytorchlightning/pytorch-lightning
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
- Record
CVE-2022-0845- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVGHSA-r5qj-cvf9-p85h
9.3
Code Injection in PyTorch Lightning
PyTorch Lightning version 1.5.10 and prior is vulnerable to code injection. An attacker could execute commands on the target OS running the operating system by setting the PL_TRAINER_GPUS when using the Trainer module. A patch is included in the 1.6.0 release.
- Record
GHSA-r5qj-cvf9-p85h- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVPYSEC-2022-181 No score
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
- Record
PYSEC-2022-181- Updated
- 2026-11-02
OSVPYSEC-2026-3969 No score
Code Injection in GitHub repository pytorchlightning/pytorch-lightning prior to 1.6.0.
- Record
PYSEC-2026-3969- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pytorch-lightningPyPI |
before 1.6.0 | 1.6.0 |
pytorch-lightningPyPI |
before 1.6.0, plus listed versions 0.0.20.10.00.20.2.20.2.3 Show 45 moreShow less0.2.40.2.4.10.2.50.2.5.10.2.5.20.2.60.30.3.10.3.20.3.30.3.40.3.4.10.3.50.3.60.3.6.10.3.6.30.3.6.40.3.6.50.3.6.60.3.6.70.3.6.80.3.6.90.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.1.20.5.1.30.5.20.5.2.10.5.30.5.3.10.5.3.20.5.3.30.6.00.7.10.7.3 |
1.6.0 |
pytorch-lightningPyPI |
before 1.6.0, plus listed versions 0.0.20.10.00.20.2.20.2.3 Show 45 moreShow less0.2.40.2.4.10.2.50.2.5.10.2.5.20.2.60.30.3.10.3.20.3.30.3.40.3.4.10.3.50.3.60.3.6.10.3.6.30.3.6.40.3.6.50.3.6.60.3.6.70.3.6.80.3.6.90.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.1.20.5.1.30.5.20.5.2.10.5.30.5.3.10.5.3.20.5.3.30.6.00.7.10.7.3 |
1.6.0 |
lightningPyPI |
before 1.6.0, plus listed versions 0.0.20.10.00.20.2.20.2.3 Show 45 moreShow less0.2.40.2.4.10.2.50.2.5.10.2.5.20.2.60.30.3.10.3.20.3.30.3.40.3.4.10.3.50.3.60.3.6.10.3.6.30.3.6.40.3.6.50.3.6.60.3.6.70.3.6.80.3.6.90.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.5.10.5.1.20.5.1.30.5.20.5.2.10.5.30.5.3.10.5.3.20.5.3.30.6.00.7.10.7.3 |
1.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0845 is a high vulnerability (CVSS 7.3) in Pytorchlightning Pytorchlightning/pytorch-lightning, published March 5, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in pytorch-lightning 1.6.0.
References
huntr.dev/bounties/a795bf93-c91e-4c79-aae8-f7d8bda92e2a
github.com/pytorchlightning/pytorch-lightning/commit/8b7a12c52e52a06408e9231647839ddb4665e8ae
nvd.nist.gov/vuln/detail/CVE-2022-0845
github.com/PyTorchLightning/pytorch-lightning/pull/12212
github.com/advisories/GHSA-r5qj-cvf9-p85h
github.com/pypa/advisory-database/tree/main/vulns/pytorch-lightning/PYSEC-2022-181.yaml
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0845.json
github.com/pytorchlightning/pytorch-lightning
Left out here: 254 versions. The JSON record has them.