Every CVE Search/ Get API key

CVE-2026-35175

Ajenti has an authorization bypass during custom package installation

7.2 HighFix available

Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
High
Availability
Low

Exploit likelihood

0.28%Up 0.2 points since Apr 7, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.2

Ajenti has an authorization bypass during custom package installation

Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.

Record
CVE-2026-35175
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
Weakness
CWE-862
Updated
2026-11-02
EUVDEUVD-2026-19424 7.2

Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.

Record
EUVD-2026-19424
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-73jv-44c3-j5p2 7.2

Ajenti has an authorization bypass during custom package installation

Impact

An authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser.

Patches

This is fixed in the version 2.2.15. Users should upgrade to this version as soon as possible.

Record
GHSA-73jv-44c3-j5p2
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
Weakness
CWE-862
Updated
2026-11-02
NVD 7.2

Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.

Record
CVE-2026-35175
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-862
Updated
2026-11-02
OSV 7.2

Ajenti has an authorization bypass during custom package installation

Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.

Record
CVE-2026-35175
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
Weakness
CWE-862
Updated
2026-11-02
OSVGHSA-73jv-44c3-j5p2 7.2

Ajenti has an authorization bypass during custom package installation

Impact

An authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser.

Patches

This is fixed in the version 2.2.15. Users should upgrade to this version as soon as possible.

Record
GHSA-73jv-44c3-j5p2
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
Weakness
CWE-862
Updated
2026-11-02
OSVPYSEC-2026-2339 7.2

Ajenti has an authorization bypass during custom package installation

Impact

An authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser.

Patches

This is fixed in the version 2.2.15. Users should upgrade to this version as soon as possible.

Record
PYSEC-2026-2339
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ajenti-panel
PyPI
before 2.2.15
2.2.15
ajenti-panel
PyPI
before 2.2.15, plus listed versions
0.100.110.120.130.14
Show 45 moreShow less
0.150.160.170.180.190.20.200.210.220.230.250.260.270.280.290.30.300.310.320.330.40.50.60.70.80.92.0.342.0.352.0.362.0.372.0.382.0.392.0.402.0.412.0.422.0.432.0.442.0.452.0.462.0.472.0.482.0.492.0.502.0.512.0.52
2.2.15

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-35175 is a high vulnerability (CVSS 7.2) in Ajenti, published April 3, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in ajenti-panel 2.2.15.

References

This page doesn't list everything

Left out here: 76 versions. The JSON record has them.

MoveEnter Open