Every CVE Search/ Get API key

CVE-2016-10321

web2py is vulnerable to password brute-force attack

9.8 CriticalFix available

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.61%Up 1.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
CVE-2016-10321
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-254
Updated
2026-11-02
CVE List No score

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
CVE-2016-10321
Updated
2026-11-02
EUVDEUVD-2022-4011 No score

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
EUVD-2022-4011
Updated
2026-11-03
GitHub AdvisoriesGHSA-gv85-wgxc-vc56 9.8

web2py is vulnerable to password brute-force attack

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
GHSA-gv85-wgxc-vc56
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
OSV 9.8

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
CVE-2016-10321
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-gv85-wgxc-vc56 9.8

web2py is vulnerable to password brute-force attack

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
GHSA-gv85-wgxc-vc56
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
OSVPYSEC-2026-569 9.8

web2py is vulnerable to password brute-force attack

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
PYSEC-2026-569
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2016-10321 9.8

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.

Record
UBUNTU-CVE-2016-10321
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4030-1 No score

web2py vulnerabilities

It was discovered that web2py does not properly check denied hosts before verifying passwords. An attacker could possibly use this issue to perform brute-force attacks. (CVE-2016-10321)

It was discovered that web2py allows remote attackers to obtain environment variable values. An attacker could possibly use this issue to gain administrative access. (CVE-2016-3952)

It was discovered that web2py uses a hardcoded encryption key. An attacker could possibly use this issue to execute arbitrary code. (CVE-2016-3953, CVE-2016-3954, CVE-2016-3957)

Record
USN-4030-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
web2py
PyPI
before 2.14.6
2.14.6
web2py
PyPI
before 2.14.6, plus listed versions
1.96.41.98.22.1.1
2.14.6
web2py
Ubuntu:16.04:LTS
before 2.12.3-1ubuntu0.1, plus listed versions
1.99.7-12.12.3-1
2.12.3-1ubuntu0.1
web2py
Ubuntu:16.04:LTS
From an advisory covering 5 CVEs
before 2.12.3-1ubuntu0.1, plus listed versions
1.99.7-12.12.3-1
2.12.3-1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-10321 is a critical vulnerability (CVSS 9.8) in Web2py, published April 10, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.61%, the 85th percentile. Fixed in web2py 2.14.6.

References

Show 8 moreShow less
MoveEnter Open