CVE-2009-2737
Roundup Improper Access Control
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
Exploit likelihood
What each source reports
NVD Score used
5.5
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
- Record
CVE-2009-2737- CVSS 2.0
- 5.5 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:P - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
- Record
CVE-2009-2737- Updated
- 2026-11-02
EUVDEUVD-2022-3443 No score
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
- Record
EUVD-2022-3443- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9rj9-5wcv-xgf2 No score
Roundup Improper Access Control
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
- Record
GHSA-9rj9-5wcv-xgf2- Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGHSA-9rj9-5wcv-xgf2 No score
Roundup Improper Access Control
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
- Record
GHSA-9rj9-5wcv-xgf2- Weakness
- CWE-284
- Updated
- 2026-11-02
OSVPYSEC-2026-744 No score
Roundup Improper Access Control
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
- Record
PYSEC-2026-744- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
roundupPyPI |
1.2 up to 1.2.1 | 1.2.1 |
roundupPyPI |
1.4 to 1.4.6 | 1.4.7 |
roundupDebian:4.0 |
before 1.2.1-10+etch1, plus listed versions 1.2.1-51.2.1-5+etch11.2.1-5+etch21.2.1-61.2.1-71.2.1-81.2.1-9 |
1.2.1-10+etch1 |
roundupDebian:5.0 |
before 1.4.4-4+lenny1, plus listed versions 1.4.4-4 |
1.4.4-4+lenny1 |
roundupPyPI |
1.2 up to 1.2.1, plus listed versions 1.2.0 |
1.2.1 |
roundupPyPI |
1.4 up to 1.4.7, plus listed versions 1.4.01.4.11.4.21.4.31.4.41.4.5.11.4.6 |
1.4.7 |
roundupPyPI |
1.2 up to 1.2.1, 1.4 up to 1.4.7, plus listed versions 1.2.01.4.01.4.11.4.21.4.31.4.41.4.5.11.4.6 |
1.2.11.4.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-2737 is a medium vulnerability (CVSS 5.5) in Toni Mueller Roundup, published April 9, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.34%, the 83rd percentile. Fixed in roundup 1.2.1.
References
secunia.com/advisories/34192
osvdb.org/56368
redhat.com/archives/fedora-package-announce/2009-March/msg00429.html
redhat.com/archives/fedora-package-announce/2009-March/msg00439.html
bugs.debian.org/cgi-bin/bugreport.cgi?bug=518768
securityfocus.com/bid/34059
Show 8 moreShow less
issues.roundup-tracker.org/issue2550521
bugzilla.redhat.com/show_bug.cgi?id=489355
debian.org/security/2009/dsa-1754
nvd.nist.gov/vuln/detail/CVE-2009-2737
github.com/roundup-tracker/roundup/blob/d24abceaa19072b28e5c8ae0db4dd341597d14fc/CHANGES.txt
sourceforge.net/p/roundup/code/ci/4081
github.com/advisories/GHSA-9rj9-5wcv-xgf2
pypi.org/project/roundup