Every CVE Search/ Get API key

CVE-2006-7225

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers...

4.3 MediumFix available

CVE-2006-7225 is a medium vulnerability (CVSS 4.3) in Perl Pcre, published December 3, 2007. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in glib2.0 2.14.3-1.

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Exploit likelihood

1.60%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Record
CVE-2006-7225
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Record
CVE-2006-7225
Updated
2026-11-02
EUVDEUVD-2006-7202 No score

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Record
EUVD-2006-7202
Updated
2026-11-03
GitHub AdvisoriesGHSA-jwp9-5mxp-g76g No score

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers...

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Record
GHSA-jwp9-5mxp-g76g
Weakness
CWE-20
Updated
2026-11-02
OSV No score

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Record
CVE-2006-7225
Updated
2026-11-02
OSVDEBIAN-CVE-2006-7225 No score

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

Record
DEBIAN-CVE-2006-7225
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
glib2.0
Debian:12
before 2.14.3-1
2.14.3-1
glib2.0
Debian:13
before 2.14.3-1
2.14.3-1
glib2.0
Debian:14
before 2.14.3-1
2.14.3-1
pcre3
Debian:12
before 6.7-1
6.7-1
pcre
Red Hat:enterprise_linux:5::client_workstation
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre
Red Hat:enterprise_linux:5::client
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-debuginfo
Red Hat:enterprise_linux:5::client
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre
Red Hat:enterprise_linux:5::server
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
Show 14 moreShow less
Affected packages
PackageAffectedFixed
pcre-debuginfo
Red Hat:enterprise_linux:5::server
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre-devel
Red Hat:enterprise_linux:5::server
before 0:6.6-2.el5_1.7
0:6.6-2.el5_1.7
pcre
Red Hat:enterprise_linux:4::as
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::as
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::as
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::desktop
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::desktop
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::es
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::es
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::es
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre
Red Hat:enterprise_linux:4::ws
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6
pcre-devel
Red Hat:enterprise_linux:4::ws
before 0:4.5-4.el4_6.6
0:4.5-4.el4_6.6

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 31 moreShow less
MoveEnter Open