CVE-2009-0398
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug...
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug-ins (aka gstreamer-plugins) 0.6.0 allows remote attackers to have an unknown impact via a crafted QuickTime media file.
Exploit likelihood
What each source reports
NVD Score used
9.3
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug-ins (aka gstreamer-plugins) 0.6.0 allows remote attackers to have an unknown impact via a crafted QuickTime media file.
- Record
CVE-2009-0398- CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug-ins (aka gstreamer-plugins) 0.6.0 allows remote attackers to have an unknown impact via a crafted QuickTime media file.
- Record
CVE-2009-0398- Updated
- 2026-11-02
EUVDEUVD-2009-0402 No score
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug-ins (aka gstreamer-plugins) 0.6.0 allows remote attackers to have an unknown impact via a crafted QuickTime media file.
- Record
EUVD-2009-0402- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6qh3-3xvg-2wvc No score
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug...
Array index error in the gst_qtp_trak_handler function in gst/qtdemux/qtdemux.c in GStreamer Plug-ins (aka gstreamer-plugins) 0.6.0 allows remote attackers to have an unknown impact via a crafted QuickTime media file.
- Record
GHSA-6qh3-3xvg-2wvc- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gstreamer-pluginsRed Hat:enterprise_linux:3::as |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-debuginfoRed Hat:enterprise_linux:3::as |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-develRed Hat:enterprise_linux:3::as |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-pluginsRed Hat:enterprise_linux:3::desktop |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-debuginfoRed Hat:enterprise_linux:3::desktop |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-develRed Hat:enterprise_linux:3::desktop |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-pluginsRed Hat:enterprise_linux:3::es |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-debuginfoRed Hat:enterprise_linux:3::es |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-develRed Hat:enterprise_linux:3::es |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-pluginsRed Hat:enterprise_linux:3::ws |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-debuginfoRed Hat:enterprise_linux:3::ws |
before 0:0.6.0-19 | 0:0.6.0-19 |
gstreamer-plugins-develRed Hat:enterprise_linux:3::ws |
before 0:0.6.0-19 | 0:0.6.0-19 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-0398 is a high vulnerability (CVSS 9.3) in Gstreamer Plug-ins, published February 3, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.19%, the 88th percentile. Fixed in gstreamer-plugins 0:0.6.0-19.
References
redhat.com/support/errata/RHSA-2009-0269.html
secunia.com/advisories/33830
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9886
openwall.com/lists/oss-security/2009/01/29/3
nvd.nist.gov/vuln/detail/CVE-2009-0398
github.com/advisories/GHSA-6qh3-3xvg-2wvc