Every CVE Search/ Get API key

CVE-2013-2116

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote...

5.0 MediumFix available

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote attackers to cause a denial of service (buffer over-read and crash) via a crafted padding length. NOTE: this might be due to an incorrect fix for CVE-2013-0169.

Exploit likelihood

3.76%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote attackers to cause a denial of service (buffer over-read and crash) via a crafted padding length. NOTE: this might be due to an incorrect fix for CVE-2013-0169.

Record
CVE-2013-2116
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote attackers to cause a denial of service (buffer over-read and crash) via a crafted padding length. NOTE: this might be due to an incorrect fix for CVE-2013-0169.

Record
CVE-2013-2116
Updated
2026-11-02
EUVDEUVD-2013-2085 No score

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote attackers to cause a denial of service (buffer over-read and crash) via a crafted padding length. NOTE: this might be due to an incorrect fix for CVE-2013-0169.

Record
EUVD-2013-2085
Updated
2026-11-03
GitHub AdvisoriesGHSA-2vj6-mvxm-4f5f No score

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote...

The _gnutls_ciphertext2compressed function in lib/gnutls_cipher.c in GnuTLS 2.12.23 allows remote attackers to cause a denial of service (buffer over-read and crash) via a crafted padding length. NOTE: this might be due to an incorrect fix for CVE-2013-0169.

Record
GHSA-2vj6-mvxm-4f5f
Weakness
CWE-20
Updated
2026-11-02
OSVBELL-CVE-2013-2116 5.0

CVE-2013-2116 does not affect BellSoft software

Record
BELL-CVE-2013-2116
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
OSVSUSE-SU-2015:0675-1 No score

Security update for gnutls

GnuTLS has been patched to ensure proper parsing of session ids during the TLS/SSL handshake. Additionally, three issues inherited from libtasn1 have been fixed.

Further information is available at http://www.gnutls.org/security.html#GNUTLS-SA-2014-3 http://www.gnutls.org/security.html#GNUTLS-SA-2014-3

These security issues have been fixed:

* Possible memory corruption during connect (CVE-2014-3466)
* Multiple boundary check issues could allow DoS (CVE-2014-3467)
* asn1_get_bit_der() can return negative bit length (CVE-2014-3468)
* Possible DoS by NULL pointer dereference (CVE-2014-3469)

Security Issue references:

* CVE-2014-3466
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3466>
Record
SUSE-SU-2015:0675-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnutls26
Debian:7
before 2.12.20-7, plus listed versions
2.12.20-6
2.12.20-7
gnutls
Red Hat:enterprise_linux:5::server
before 0:1.4.1-10.el5_9.2
0:1.4.1-10.el5_9.2
gnutls-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.4.1-10.el5_9.2
0:1.4.1-10.el5_9.2
gnutls-devel
Red Hat:enterprise_linux:5::server
before 0:1.4.1-10.el5_9.2
0:1.4.1-10.el5_9.2
gnutls-utils
Red Hat:enterprise_linux:5::server
before 0:1.4.1-10.el5_9.2
0:1.4.1-10.el5_9.2
gnutls
Red Hat:enterprise_linux:6::client
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-debuginfo
Red Hat:enterprise_linux:6::client
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-utils
Red Hat:enterprise_linux:6::client
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-devel
Red Hat:enterprise_linux:6::client
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-guile
Red Hat:enterprise_linux:6::client
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
Show 16 moreShow less
Affected packages
PackageAffectedFixed
gnutls
Red Hat:enterprise_linux:6::computenode
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-debuginfo
Red Hat:enterprise_linux:6::computenode
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-utils
Red Hat:enterprise_linux:6::computenode
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-devel
Red Hat:enterprise_linux:6::computenode
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-guile
Red Hat:enterprise_linux:6::computenode
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls
Red Hat:enterprise_linux:6::server
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-debuginfo
Red Hat:enterprise_linux:6::server
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-devel
Red Hat:enterprise_linux:6::server
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-utils
Red Hat:enterprise_linux:6::server
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-guile
Red Hat:enterprise_linux:6::server
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls
Red Hat:enterprise_linux:6::workstation
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-debuginfo
Red Hat:enterprise_linux:6::workstation
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-devel
Red Hat:enterprise_linux:6::workstation
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-utils
Red Hat:enterprise_linux:6::workstation
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
gnutls-guile
Red Hat:enterprise_linux:6::workstation
before 0:2.8.5-10.el6_4.2
0:2.8.5-10.el6_4.2
rhev-hypervisor6
Red Hat:enterprise_linux:6::hypervisor
before 0:6.4-20130709.0.el6_4
0:6.4-20130709.0.el6_4

History

History
RecordedChangedSources
facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-2116 is a medium vulnerability (CVSS 5.0) in Gnu Gnutls, published May 29, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.76%, the 89th percentile. Fixed in gnutls26 2.12.20-7.

References

Show 41 moreShow less
MoveEnter Open