Every CVE Search/ Get API key

CVE-2015-3256

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory...

4.6 MediumPublic exploitFix available

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory corruption and polkitd daemon crash) and possibly gain privileges via unspecified vectors, related to "javascript rule evaluation."

Exploit likelihood

0.35%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory corruption and polkitd daemon crash) and possibly gain privileges via unspecified vectors, related to "javascript rule evaluation."

Record
CVE-2015-3256
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory corruption and polkitd daemon crash) and possibly gain privileges via unspecified vectors, related to "javascript rule evaluation."

Record
CVE-2015-3256
Updated
2026-11-02
EUVDEUVD-2015-3309 No score

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory corruption and polkitd daemon crash) and possibly gain privileges via unspecified vectors, related to "javascript rule evaluation."

Record
EUVD-2015-3309
Updated
2026-11-03
GitHub AdvisoriesGHSA-779g-mjcq-vffm No score

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory...

PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory corruption and polkitd daemon crash) and possibly gain privileges via unspecified vectors, related to "javascript rule evaluation."

Record
GHSA-779g-mjcq-vffm
Updated
2026-11-02
OSVMGASA-2015-0262 No score

Updated polkit package fixes security vulnerabilities

Local privilege escalation in polkit before 0.113 due to predictable authentication session cookie values (CVE-2015-4625).

Various memory corruption vulnerabilities in polkit before 0.113 in the use of the JavaScript interpreter, possibly leading to local privilege escalation (CVE-2015-3256).

Memory corruption vulnerability in polkit before 0.113 in handling duplicate action IDs, possibly leading to local privilege escalation (CVE-2015-3255).

Denial of service issue in polkit before 0.113 which allowed any local user to crash polkitd (CVE-2015-3218).

Record
MGASA-2015-0262
Updated
2026-11-02
OSVopenSUSE-SU-2024:10436-1 No score

libpolkit0-0.113-3.4 on GA media

These are all security issues fixed in the libpolkit0-0.113-3.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10436-1
Updated
2026-11-02
OSVSUSE-SU-2015:1838-1 No score

Security update for polkit

polkit was updated to the 0.113 release, fixing security issues and bugs.

Security issues fixed:

  • Fixes CVE-2015-4625, a local privilege escalation due to predictable authentication session cookie values. Thanks to Tavis Ormandy, Google Project Zero for reporting this issue. For the future, authentication agents are encouraged to use PolkitAgentSession instead of using the D-Bus agent response API directly. (bsc#935119)
  • Fixes CVE-2015-3256, various memory corruption vulnerabilities in use of the JavaScript interpreter, possibly leading to local privilege escalation. (bsc#943816)
  • Fixes CVE-2015-3255, a memory corruption vulnerability in handling duplicate action IDs, possibly leading to local privilege escalation. Thanks to Laurent Bigonville for reporting this issue. (bsc#939246)
  • Fixes CVE-2015-3218, which allowed any local user to crash polkitd. Thanks to Tavis Ormandy, Google Project Zero, for reporting this issue. (bsc#933922)

Other issues fixed:

  • On systemd-213 and later, the 'active' state is shared across all sessions of an user, instead of being tracked separately.
  • pkexec, when not given a program to execute, runs the users shell by default.
  • Fixed shutdown problems on powerpc64le (bsc#950114)
  • polkit had a memory leak (bsc#912889)
Record
SUSE-SU-2015:1838-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
polkit
Mageia:4
before 0.113-1.mga4
0.113-1.mga4
polkit
Mageia:5
before 0.113-1.mga5
0.113-1.mga5
polkit
Red Hat:enterprise_linux:7::client
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-debuginfo
Red Hat:enterprise_linux:7::client
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-devel
Red Hat:enterprise_linux:7::client
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-docs
Red Hat:enterprise_linux:7::client
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit
Red Hat:enterprise_linux:7::computenode
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-debuginfo
Red Hat:enterprise_linux:7::computenode
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-devel
Red Hat:enterprise_linux:7::computenode
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-docs
Red Hat:enterprise_linux:7::computenode
before 0:0.112-6.el7_2
0:0.112-6.el7_2
Show 13 moreShow less
Affected packages
PackageAffectedFixed
polkit
Red Hat:enterprise_linux:7::server
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-debuginfo
Red Hat:enterprise_linux:7::server
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-devel
Red Hat:enterprise_linux:7::server
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-docs
Red Hat:enterprise_linux:7::server
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit
Red Hat:enterprise_linux:7::workstation
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-debuginfo
Red Hat:enterprise_linux:7::workstation
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-devel
Red Hat:enterprise_linux:7::workstation
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit-docs
Red Hat:enterprise_linux:7::workstation
before 0:0.112-6.el7_2
0:0.112-6.el7_2
polkit
SUSE:Linux Enterprise Desktop 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Software Development Kit 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Server 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Server for SAP Applications 12
before 0.113-4.1
0.113-4.1
polkit
SUSE:Linux Enterprise Workstation Extension 12
before 0.113-4.1
0.113-4.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubpuglia-ryan/S-V-Project-Implementation-of-CVE-2015-32562026-05-12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-3256 is a medium vulnerability (CVSS 4.6) in Polkit Project Polkit, published July 5, 2015. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 29th percentile. Fixed in polkit 0.113-1.mga4.

References

Show 25 moreShow less
MoveEnter Open