CVE-2016-9590
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat...
CVE-2016-9590 is a medium vulnerability (CVSS 6.5) in Openstack Puppet-swift, published April 26, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in puppet-module-swift 9.4.4-1.
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
CVE-2016-9590- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
EUVDEUVD-2016-10394
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
EUVD-2016-10394- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7q5j-cmrw-cmmc
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat...
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
GHSA-7q5j-cmrw-cmmc- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
NVD
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
CVE-2016-9590- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
CVE-2016-9590- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2016-9590
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
DEBIAN-CVE-2016-9590- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Show 4 moreShow less
OSVRHSA-2017:0200
6.5
Red Hat Security Advisory: puppet-swift security update
- Record
RHSA-2017:0200- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - Updated
- 2026-11-02
OSVRHSA-2017:0359
6.5
Red Hat Security Advisory: openstack-puppet-modules security update
- Record
RHSA-2017:0359- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - Updated
- 2026-11-02
OSVRHSA-2017:0361
6.5
Red Hat Security Advisory: openstack-puppet-modules security update
- Record
RHSA-2017:0361- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2016-9590
6.5
puppet-swift before versions 8.2.1, 9.4.4 is vulnerable to an information-disclosure in Red Hat OpenStack Platform director's installation of Object Storage (swift). During installation, the Puppet script responsible for deploying the service incorrectly removes and recreates the proxy-server.conf file with world-readable permissions.
- Record
UBUNTU-CVE-2016-9590- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
puppet-module-swiftDebian:12 |
before 9.4.4-1 | 9.4.4-1 |
puppet-module-swiftDebian:13 |
before 9.4.4-1 | 9.4.4-1 |
puppet-swiftRed Hat:openstack:10::el7 |
before 0:9.4.3-3.el7ost | 0:9.4.3-3.el7ost |
openstack-puppet-modulesRed Hat:openstack:9::el7 |
before 1:8.1.10-2.el7ost | 1:8.1.10-2.el7ost |
openstack-puppet-modulesRed Hat:openstack:8::el7 |
before 1:7.1.5-2.el7ost | 1:7.1.5-2.el7ost |
puppet-module-swiftUbuntu:16.04:LTS |
All versions, plus listed versions 7.0.0-1 |
None known |
puppet-module-swiftUbuntu:18.04:LTS |
before 9.4.4-1 | 9.4.4-1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
rhn.redhat.com/errata/RHSA-2017-0359.html
securityfocus.com/bid/95448
rhn.redhat.com/errata/RHSA-2017-0361.html
rhn.redhat.com/errata/RHSA-2017-0200.html
bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9590
nvd.nist.gov/vuln/detail/CVE-2016-9590
Show 13 moreShow less
github.com/advisories/GHSA-7q5j-cmrw-cmmc
security-tracker.debian.org/tracker/CVE-2016-9590
access.redhat.com/errata/RHSA-2017:0200
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1410293
security.access.redhat.com/data/csaf/v2/advisories/2017/rhsa-2017_0200.json
access.redhat.com/security/cve/CVE-2016-9590
cve.org/CVERecord?id=CVE-2016-9590
access.redhat.com/errata/RHSA-2017:0359
security.access.redhat.com/data/csaf/v2/advisories/2017/rhsa-2017_0359.json
access.redhat.com/errata/RHSA-2017:0361
security.access.redhat.com/data/csaf/v2/advisories/2017/rhsa-2017_0361.json
ubuntu.com/security/CVE-2016-9590