CVE-2017-2628
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly...
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.
- Record
CVE-2017-2628- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.
- Record
CVE-2017-2628- Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2017-11789 No score
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.
- Record
EUVD-2017-11789- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9v4c-xqrp-4vv9
9.8
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly...
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.
- Record
GHSA-9v4c-xqrp-4vv9- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
9.8
curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.
- Record
CVE-2017-2628- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVRHSA-2017:0847
4.8
Red Hat Security Advisory: curl security update
- Record
RHSA-2017:0847- CVSS 3.0
- 4.8 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
curlRed Hat:enterprise_linux:6::client |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curl-debuginfoRed Hat:enterprise_linux:6::client |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurlRed Hat:enterprise_linux:6::client |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurl-develRed Hat:enterprise_linux:6::client |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curlRed Hat:enterprise_linux:6::computenode |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curl-debuginfoRed Hat:enterprise_linux:6::computenode |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurlRed Hat:enterprise_linux:6::computenode |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurl-develRed Hat:enterprise_linux:6::computenode |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curlRed Hat:enterprise_linux:6::server |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curl-debuginfoRed Hat:enterprise_linux:6::server |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
Show 6 moreShow less
| Package | Affected | Fixed |
|---|---|---|
libcurlRed Hat:enterprise_linux:6::server |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurl-develRed Hat:enterprise_linux:6::server |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curlRed Hat:enterprise_linux:6::workstation |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
curl-debuginfoRed Hat:enterprise_linux:6::workstation |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurlRed Hat:enterprise_linux:6::workstation |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
libcurl-develRed Hat:enterprise_linux:6::workstation |
before 0:7.19.7-53.el6_9 | 0:7.19.7-53.el6_9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-2628 is a critical vulnerability (CVSS 9.8) in Curl, published March 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.80%, the 90th percentile. Fixed in curl 0:7.19.7-53.el6_9.