CVE-2017-7509
An input validation error was found in Red Hat Certificate System's handling of client provided...
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
3.5
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
- Record
CVE-2017-7509- CVSS 3.0
- 3.5 Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2017-16526
3.5
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
- Record
EUVD-2017-16526- CVSS 3.0
- 3.5 Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2v3w-p5pg-rgxq
6.5
An input validation error was found in Red Hat Certificate System's handling of client provided...
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
- Record
GHSA-2v3w-p5pg-rgxq- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
3.5
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
- Record
CVE-2017-7509- CVSS 3.0
- 3.5 Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVRHSA-2017:2560
3.5
Red Hat Security Advisory: Red Hat Certificate System 8 security, bug fix, and enhancement update
- Record
RHSA-2017:2560- CVSS 3.0
- 3.5 Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pki-caRed Hat:certificate_system:8::el5 |
before 0:8.1.9-2.el5pki | 0:8.1.9-2.el5pki |
pki-commonRed Hat:certificate_system:8::el5 |
before 0:8.1.20-1.el5pki | 0:8.1.20-1.el5pki |
pki-common-javadocRed Hat:certificate_system:8::el5 |
before 0:8.1.20-1.el5pki | 0:8.1.20-1.el5pki |
pki-kraRed Hat:certificate_system:8::el5 |
before 0:8.1.7-2.el5pki | 0:8.1.7-2.el5pki |
pki-silentRed Hat:certificate_system:8::el5 |
before 0:8.1.2-3.el5pki | 0:8.1.2-3.el5pki |
pki-tpsRed Hat:certificate_system:8::el5 |
before 0:8.1.30-1.el5pki | 0:8.1.30-1.el5pki |
pki-utilRed Hat:certificate_system:8::el5 |
before 0:8.1.3-2.el5pki | 0:8.1.3-2.el5pki |
pki-util-javadocRed Hat:certificate_system:8::el5 |
before 0:8.1.3-2.el5pki | 0:8.1.3-2.el5pki |
redhat-pki-ca-uiRed Hat:certificate_system:8::el5 |
before 0:8.1.1-2.el5pki | 0:8.1.1-2.el5pki |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7509 is a low vulnerability (CVSS 3.5) in Red Hat Certificate System, published July 26, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.73%, the 54th percentile. Fixed in pki-ca 0:8.1.9-2.el5pki.