Every CVE Search/ Get API key

CVE-2014-8184

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow...

7.8 HighFix available

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.55%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
CVE-2014-8184
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2014-8025 7.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
EUVD-2014-8025
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-4v7c-4xff-r4v7 8.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow...

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
GHSA-4v7c-4xff-r4v7
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-121
Updated
2026-11-02
NVD 7.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
CVE-2014-8184
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-121, CWE-119
Updated
2026-11-02
OSV 7.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
CVE-2014-8184
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-8184 7.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
DEBIAN-CVE-2014-8184
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVRHSA-2017:3111 7.8

Red Hat Security Advisory: liblouis security update

Record
RHSA-2017:3111
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2014-8184 7.8

A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.

Record
UBUNTU-CVE-2014-8184
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2017:3078-1 No score

Security update for liblouis

This update for liblouis fixes the following issues:

Security issues fixed:

  • CVE-2017-15101: Buffer overflow in findTable (bsc#1067336).
  • CVE-2014-8184: stack-based buffer overflow in findTable() (bsc#1062458).
Record
SUSE-SU-2017:3078-1
Updated
2026-11-02
OSVUSN-3474-1 No score

liblouis vulnerability

Raphael Sanchez Prudencio discovered that Liblouis incorrectly handled certain files. If a user were tricked into opening a crafted file, an attacker could possibly use this to cause a denial of service or potentially execute arbitrary code.

Record
USN-3474-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
liblouis
Debian:12
before 2.6.2-1
2.6.2-1
liblouis
Debian:13
before 2.6.2-1
2.6.2-1
liblouis
Debian:14
before 2.6.2-1
2.6.2-1
liblouis
Red Hat:enterprise_linux:7::client
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-debuginfo
Red Hat:enterprise_linux:7::client
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-python
Red Hat:enterprise_linux:7::client
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-devel
Red Hat:enterprise_linux:7::client
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-doc
Red Hat:enterprise_linux:7::client
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-utils
Red Hat:enterprise_linux:7::client
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis
Red Hat:enterprise_linux:7::server
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
Show 16 moreShow less
Affected packages
PackageAffectedFixed
liblouis-debuginfo
Red Hat:enterprise_linux:7::server
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-python
Red Hat:enterprise_linux:7::server
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-devel
Red Hat:enterprise_linux:7::server
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-doc
Red Hat:enterprise_linux:7::server
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-utils
Red Hat:enterprise_linux:7::server
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis
Red Hat:enterprise_linux:7::workstation
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-debuginfo
Red Hat:enterprise_linux:7::workstation
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-python
Red Hat:enterprise_linux:7::workstation
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-devel
Red Hat:enterprise_linux:7::workstation
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-doc
Red Hat:enterprise_linux:7::workstation
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis-utils
Red Hat:enterprise_linux:7::workstation
before 0:2.5.2-11.el7_4
0:2.5.2-11.el7_4
liblouis
SUSE:Linux Enterprise Server 11 SP4
before 1.7.0-1.3.6.1
1.7.0-1.3.6.1
python-louis
SUSE:Linux Enterprise Server 11 SP4
before 1.7.0-1.3.6.1
1.7.0-1.3.6.1
liblouis
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.7.0-1.3.6.1
1.7.0-1.3.6.1
python-louis
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.7.0-1.3.6.1
1.7.0-1.3.6.1
liblouis
Ubuntu:14.04:LTS
before 2.5.3-2ubuntu1.2, plus listed versions
2.5.3-22.5.3-2ubuntu12.5.3-2ubuntu1.1
2.5.3-2ubuntu1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8184 is a high vulnerability (CVSS 7.8) in Liblouis, published December 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.55%, the 75th percentile. Fixed in liblouis 2.6.2-1.

References

Show 36 moreShow less
MoveEnter Open