Every CVE Search/ Get API key

CVE-2017-10906

Fluentd Escape Sequence Injection Vulnerability

9.8 CriticalFix available

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.58%Up 2.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Record
CVE-2017-10906
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Record
CVE-2017-10906
Updated
2026-11-02
EUVDEUVD-2022-2613 No score

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Record
EUVD-2022-2613
Updated
2026-11-03
GitHub AdvisoriesGHSA-5jrp-w8fr-mrww 9.8

Fluentd Escape Sequence Injection Vulnerability

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Record
GHSA-5jrp-w8fr-mrww
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Record
CVE-2017-10906
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-5jrp-w8fr-mrww 9.8

Fluentd Escape Sequence Injection Vulnerability

Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.

Record
GHSA-5jrp-w8fr-mrww
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2018:2225 5.3

Red Hat Security Advisory: fluentd security update

Record
RHSA-2018:2225
CVSS 3.0
5.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fluentd
RubyGems
0.12.29 up to 0.12.41
0.12.41
fluentd
RubyGems
0.12.29 up to 0.12.41, plus listed versions
0.12.300.12.310.12.320.12.330.12.34
Show 6 moreShow less
0.12.350.12.360.12.370.12.380.12.390.12.40
0.12.41
fluentd
Red Hat:openstack-optools:13::el7
before 0:0.12.41-1.el7
0:0.12.41-1.el7

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-10906 is a critical vulnerability (CVSS 9.8) in Cloud Native Computing Foundation (cncf) Fluentd, published December 8, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.58%, the 91st percentile. Fixed in fluentd 0.12.41.

References

Show 7 moreShow less
MoveEnter Open