Every CVE Search/ Get API key

CVE-2018-15978

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful...

7.5 HighFix available

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

7.43%Up 2.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

Record
CVE-2018-15978
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

Record
CVE-2018-15978
Updated
2026-11-02
EUVDEUVD-2018-7834 No score

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

Record
EUVD-2018-7834
Updated
2026-11-03
GitHub AdvisoriesGHSA-q34p-wrjp-g6wh 7.5

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful...

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

Record
GHSA-q34p-wrjp-g6wh
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
OSVRHSA-2018:3618 6.5

Red Hat Security Advisory: flash-plugin security update

Record
RHSA-2018:3618
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2018-0453 No score

Updated flash-player-plugin packages fix security vulnerability

An important vulnerability in Adobe Flash Player 31.0.0.122 and earlier versions. Successful exploitation could lead to information disclosure. (CVE-2018-15978)

Record
MGASA-2018-0453
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-player-plugin
Mageia:6
before 31.0.0.148-1.mga6.nonfree
31.0.0.148-1.mga6.nonfree
flash-plugin
Red Hat:rhel_extras:6
before 0:31.0.0.148-1.el6_10
0:31.0.0.148-1.el6_10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-15978 is a high vulnerability (CVSS 7.5) in Adobe Flash Player, published November 15, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.43%, the 94th percentile. Fixed in flash-player-plugin 31.0.0.148-1.mga6.nonfree.

References

Show 7 moreShow less
MoveEnter Open