Every CVE Search/ Get API key

CVE-2019-10159

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to...

4.3 MediumFix available

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to an improper authorization in the migration log controller. An attacker with access to an unprivileged user can access all VM migration logs available.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.70%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 4.3

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to an improper authorization in the migration log controller. An attacker with access to an unprivileged user can access all VM migration logs available.

Record
CVE-2019-10159
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-285
Updated
2026-11-02
EUVDEUVD-2019-2192 4.3

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to an improper authorization in the migration log controller. An attacker with access to an unprivileged user can access all VM migration logs available.

Record
EUVD-2019-2192
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-whhr-m9m3-wj45 4.3

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to...

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to an improper authorization in the migration log controller. An attacker with access to an unprivileged user can access all VM migration logs available.

Record
GHSA-whhr-m9m3-wj45
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-285
Updated
2026-11-02
NVD 4.3

cfme-gemset versions 5.10.4.3 and below, 5.9.9.3 and below are vulnerable to a data leak, due to an improper authorization in the migration log controller. An attacker with access to an unprivileged user can access all VM migration logs available.

Record
CVE-2019-10159
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-285
Updated
2026-11-02
OSVRHSA-2019:2466 4.3

Red Hat Security Advisory: CloudForms 4.7.8 security, bug fix and enhancement update

Record
RHSA-2019:2466
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ansible-tower
Red Hat:cloudforms_managementengine:5.10::el7
before 0:3.5.1-1.el7at
0:3.5.1-1.el7at
ansible-tower-server
Red Hat:cloudforms_managementengine:5.10::el7
before 0:3.5.1-1.el7at
0:3.5.1-1.el7at
ansible-tower-setup
Red Hat:cloudforms_managementengine:5.10::el7
before 0:3.5.1-1.el7at
0:3.5.1-1.el7at
ansible-tower-ui
Red Hat:cloudforms_managementengine:5.10::el7
before 0:3.5.1-1.el7at
0:3.5.1-1.el7at
ansible-tower-venv-ansible
Red Hat:cloudforms_managementengine:5.10::el7
before 0:3.5.1-1.el7at
0:3.5.1-1.el7at
ansible-tower-venv-tower
Red Hat:cloudforms_managementengine:5.10::el7
before 0:3.5.1-1.el7at
0:3.5.1-1.el7at
cfme
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-amazon-smartstate
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-appliance
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-appliance-common
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
Show 8 moreShow less
Affected packages
PackageAffectedFixed
cfme-appliance-debuginfo
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-appliance-tools
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-debuginfo
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-gemset
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
cfme-gemset-debuginfo
Red Hat:cloudforms_managementengine:5.10::el7
before 0:5.10.8.0-1.el7cf
0:5.10.8.0-1.el7cf
rubygem-nokogiri
Red Hat:cloudforms_managementengine:5.10::el7
before 0:1.8.5-1.el7cf
0:1.8.5-1.el7cf
rubygem-nokogiri-debuginfo
Red Hat:cloudforms_managementengine:5.10::el7
before 0:1.8.5-1.el7cf
0:1.8.5-1.el7cf
rubygem-nokogiri-doc
Red Hat:cloudforms_managementengine:5.10::el7
before 0:1.8.5-1.el7cf
0:1.8.5-1.el7cf

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-10159 is a medium vulnerability (CVSS 4.3) in Red Hat Cfme, published June 14, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.70%, the 53rd percentile. Fixed in ansible-tower 0:3.5.1-1.el7at.

References

Show 25 moreShow less
MoveEnter Open