Every CVE Search/ Get API key

CVE-2019-20921

Cross-site scripting in bootstrap-select

6.1 MediumFix available

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.74%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Record
CVE-2019-20921
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Record
CVE-2019-20921
Updated
2026-11-02
EUVDEUVD-2021-0995 No score

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Record
EUVD-2021-0995
Updated
2026-11-03
GitHub AdvisoriesGHSA-7c82-mp33-r854 5.3

Cross-site scripting in bootstrap-select

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Record
GHSA-7c82-mp33-r854
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
GitHub AdvisoriesGHSA-9r7h-6639-v5mw No score

Cross-Site Scripting in bootstrap-select

Versions of bootstrap-select prior to 1.13.6 are vulnerable to Cross-Site Scripting (XSS). The package does not escape title values on <option> tags. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 1.13.6 or later.

Record
GHSA-9r7h-6639-v5mw
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Record
CVE-2019-20921
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-7c82-mp33-r854 5.3

Cross-site scripting in bootstrap-select

bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Record
GHSA-7c82-mp33-r854
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVRHSA-2021:1169 7.5

Red Hat Security Advisory: RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] security, bug fix, enhancement

Record
RHSA-2021:1169
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVRHSA-2021:1186 7.3

Red Hat Security Advisory: RHV Manager (ovirt-engine) 4.4.z [ovirt-4.4.5] 0-day security, bug fix, enhance

Record
RHSA-2021:1186
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVGHSA-9r7h-6639-v5mw No score

Cross-Site Scripting in bootstrap-select

Versions of bootstrap-select prior to 1.13.6 are vulnerable to Cross-Site Scripting (XSS). The package does not escape title values on <option> tags. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 1.13.6 or later.

Record
GHSA-9r7h-6639-v5mw
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
bootstrap-select
npm
before 1.13.6
1.13.6
bootstrap-select
NuGet
before 1.13.6
1.13.6
bootstrap-select
NuGet
before 1.13.6, plus listed versions
1.10.01.11.01.11.11.11.21.12.0
Show 25 moreShow less
1.12.11.12.21.12.31.12.41.13.01.13.0-alpha1.13.0-beta1.13.11.13.21.13.31.13.41.13.51.3.41.3.51.4.11.5.41.6.21.6.31.6.41.7.21.7.51.8.01.8.11.9.31.9.4
1.13.6
ovirt-web-ui
Red Hat:rhev_manager:4.4:el8
before 0:1.6.7-1.el8ev
0:1.6.7-1.el8ev
ovirt-engine
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-backend
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-dbscripts
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-health-check-bundler
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-restapi
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
Show 15 moreShow less
Affected packages
PackageAffectedFixed
ovirt-engine-setup-base
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup-plugin-cinderlib
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup-plugin-imageio
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup-plugin-ovirt-engine
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup-plugin-ovirt-engine-common
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup-plugin-vmconsole-proxy-helper
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-setup-plugin-websocket-proxy
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-tools
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-tools-backup
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-vmconsole-proxy-helper
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-webadmin-portal
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-websocket-proxy
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
python3-ovirt-engine-lib
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
rhvm
Red Hat:rhev_manager:4.4:el8
before 0:4.4.5.9-0.1.el8ev
0:4.4.5.9-0.1.el8ev
ovirt-engine-ui-extensions
Red Hat:rhev_manager:4.4:el8
before 0:1.2.5-1.el8ev
0:1.2.5-1.el8ev

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-20921 is a medium vulnerability (CVSS 6.1) in Snapappointments Bootstrap-select, published September 3, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.74%, the 77th percentile. Fixed in bootstrap-select 1.13.6.

References

Show 60 moreShow less
MoveEnter Open