Every CVE Search/ Get API key

CVE-2022-2568

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a...

6.5 MediumFix available

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a remote authenticated user with 'change user' permissions to modify the account settings of the superuser account and also remove the superuser privileges.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.98%Down 0.1 points since Aug 19, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a remote authenticated user with 'change user' permissions to modify the account settings of the superuser account and also remove the superuser privileges.

Record
CVE-2022-2568
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-269
Updated
2026-11-02
CVE List No score

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a remote authenticated user with 'change user' permissions to modify the account settings of the superuser account and also remove the superuser privileges.

Record
CVE-2022-2568
Updated
2026-11-02
EUVDEUVD-2022-34821 No score

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a remote authenticated user with 'change user' permissions to modify the account settings of the superuser account and also remove the superuser privileges.

Record
EUVD-2022-34821
Updated
2026-11-03
GitHub AdvisoriesGHSA-j928-ww9w-w7hg 6.5

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a...

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a remote authenticated user with 'change user' permissions to modify the account settings of the superuser account and also remove the superuser privileges.

Record
GHSA-j928-ww9w-w7hg
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-269
Updated
2026-11-02
OSVRHSA-2022:6078 7.2

Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.1.3 security and bug fix update

Record
RHSA-2022:6078
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2022:6079 7.2

Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.2.0 Product Security Update

Record
RHSA-2022:6079
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-2568 6.5

A privilege escalation flaw was found in the Ansible Automation Platform. This flaw allows a remote authenticated user with 'change user' permissions to modify the account settings of the superuser account and also remove the superuser privileges.

Record
UBUNTU-CVE-2022-2568
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
python-galaxy-ng
Red Hat:ansible_automation_platform:2.1::el8
before 0:4.4.4-1.el8pc
0:4.4.4-1.el8pc
python38-galaxy-ng
Red Hat:ansible_automation_platform:2.1::el8
before 0:4.4.4-1.el8pc
0:4.4.4-1.el8pc
python39-galaxy-ng
Red Hat:ansible_automation_platform:2.2::el8
before 0:4.5.0-4.el8ap
0:4.5.0-4.el8ap
python3x-galaxy-ng
Red Hat:ansible_automation_platform:2.2::el8
before 0:4.5.0-4.el8ap
0:4.5.0-4.el8ap
python-galaxy-ng
Red Hat:ansible_automation_platform:2.2::el9
before 0:4.5.0-4.el9ap
0:4.5.0-4.el9ap
python3-galaxy-ng
Red Hat:ansible_automation_platform:2.2::el9
before 0:4.5.0-4.el9ap
0:4.5.0-4.el9ap
ansible
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
1.1+dfsg-11.3.4+dfsg-11.4.0+dfsg-11.4.1+dfsg-11.4.3+dfsg-1
Show 5 moreShow less
1.4.4+dfsg-11.5.4+dfsg-11.5.4+dfsg-1ubuntu0.1~esm11.5.4+dfsg-1ubuntu0.1~esm21.5.4+dfsg-1ubuntu0.1~esm3
None known
ansible
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.9.2+dfsg-21.9.4-12.0.0.2-22.0.0.2-2ubuntu12.0.0.2-2ubuntu1.1
Show 8 moreShow less
2.0.0.2-2ubuntu1.22.0.0.2-2ubuntu1.32.0.0.2-2ubuntu1.3+esm12.0.0.2-2ubuntu1.3+esm22.0.0.2-2ubuntu1.3+esm32.0.0.2-2ubuntu1.3+esm42.0.0.2-2ubuntu1.3+esm52.0.0.2-2ubuntu1.3+esm6
None known
ansible
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
2.3.1.0+dfsg-22.5.0+dfsg-12.5.1+dfsg-12.5.1+dfsg-1ubuntu0.12.5.1+dfsg-1ubuntu0.1+esm1
Show 4 moreShow less
2.5.1+dfsg-1ubuntu0.1+esm22.5.1+dfsg-1ubuntu0.1+esm32.5.1+dfsg-1ubuntu0.1+esm42.5.1+dfsg-1ubuntu0.1+esm5
None known
ansible
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
2.8.3+dfsg-12.8.6+dfsg-12.9.2+dfsg-12.9.4+dfsg-12.9.6+dfsg-12.9.6+dfsg-1ubuntu0.1~esm12.9.6+dfsg-1ubuntu0.1~esm22.9.6+dfsg-1ubuntu0.1~esm3
None known
Show 10 moreShow less
Affected packages
PackageAffectedFixed
ansible-core
Ubuntu:22.04:LTS
All versions, plus listed versions
2.12.0-12.12.0-1ubuntu0.1
None known
ansible
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
2.10.7+merged+base+2.10.8+dfsg-12.10.7+merged+base+2.10.8+dfsg-1ubuntu0.1~esm12.10.7+merged+base+2.10.8+dfsg-1ubuntu0.1~esm4
None known
ansible
Ubuntu:24.04:LTS
All versions, plus listed versions
7.7.0+dfsg-17.7.0+dfsg-39.2.0+dfsg-0ubuntu49.2.0+dfsg-0ubuntu5
None known
ansible-core
Ubuntu:24.04:LTS
All versions, plus listed versions
2.14.9-22.14.11-12.14.11-22.14.13-12.16.3-0ubuntu12.16.3-0ubuntu2
None known
ansible
Ubuntu:25.10
All versions, plus listed versions
11.2.0+dfsg-112.0.0~a2+dfsg-112.0.0~a4+dfsg-112.0.0~a6+dfsg-112.0.0~b1+dfsg-1
None known
ansible-core
Ubuntu:25.10
All versions, plus listed versions
2.18.1-4ubuntu12.19.0~beta4-1ubuntu12.19.0-1ubuntu1
None known
ansible
Ubuntu:26.10
All versions, plus listed versions
13.1.0+dfsg-1ubuntu113.4.0+dfsg-1
None known
ansible-core
Ubuntu:26.10
All versions, plus listed versions
2.20.1-12.21.1~rc1-12.21.1~rc1-22.21.1~rc1-2ubuntu12.22.0~beta2-1
None known
ansible
Ubuntu:26.04:LTS
All versions, plus listed versions
12.0.0~b1+dfsg-112.0.0+dfsg-112.2.0+dfsg-113.1.0+dfsg-113.1.0+dfsg-1ubuntu1
None known
ansible-core
Ubuntu:26.04:LTS
All versions, plus listed versions
2.19.0-1ubuntu12.19.4-12.20.1-1
None known

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-2568 is a medium vulnerability (CVSS 6.5) in Red Hat Ansible Automation Platform, published August 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in python-galaxy-ng 0:4.4.4-1.el8pc.

References

Show 5 moreShow less
MoveEnter Open