Every CVE Search/ Get API key

CVE-2012-1093

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink...

7.8 HighFix available

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.57%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
CVE-2012-1093
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.9 MediumAV:L/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-59
Updated
2026-11-02
CVE List No score

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
CVE-2012-1093
Updated
2026-11-02
EUVDEUVD-2012-1130 No score

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
EUVD-2012-1130
Updated
2026-11-03
GitHub AdvisoriesGHSA-2qxv-mghj-hfhr No score

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink...

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
GHSA-2qxv-mghj-hfhr
Weakness
CWE-59
Updated
2026-11-02
OSV 7.8

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
CVE-2012-1093
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2012-1093 7.8

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
DEBIAN-CVE-2012-1093
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2012-1093 7.8

The init script in the Debian x11-common package before 1:7.6+12 is vulnerable to a symlink attack that can lead to a privilege escalation during package installation.

Record
UBUNTU-CVE-2012-1093
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xorg
Debian:12
before 1:7.6+12
1:7.6+12
xorg
Debian:13
before 1:7.6+12
1:7.6+12
xorg
Debian:14
before 1:7.6+12
1:7.6+12

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-1093 is a high vulnerability (CVSS 7.8) in Debian X11-common, published February 21, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in xorg 1:7.6+12.

References

Show 5 moreShow less
MoveEnter Open